summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxeruf2022-08-28 20:50:07 +0200
committerxeruf2022-08-28 20:50:07 +0200
commitc887d68036cb41da3fc361dc049bfb41345546be (patch)
treec02b8bad909fdb2372d8d88709fe8b7fdbf48cc0
parent6f148aca69f78eb4ff21df3e61172f40b555bdc8 (diff)
downloadaur-c887d68036cb41da3fc361dc049bfb41345546be.tar.gz
Add the modules
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcb6a27ca877..1fbf577888f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-pkgbase = context
- pkgdesc = ConTeXt LMTX, the Lean and Mean TeX eXperience with Lua, MetaPost, TeX, and XML
- pkgver = 2022.07.06_21.42
+pkgbase = context-modules
+ pkgdesc = ConTeXt LMTX with all ConTeXt Garden modules
+ pkgver = 2022.08.25_19.21
pkgrel = 1
url = https://wiki.contextgarden.net/Installation
- install = context.install
arch = x86_64
license = GPL
provides = context
provides = context-lmtx
- replaces = context-bin
source = http://lmtx.pragma-ade.nl/install-lmtx/context-linux-64.zip
sha256sums = SKIP
-pkgname = context
+pkgname = context-modules
diff --git a/PKGBUILD b/PKGBUILD
index d4398bfbba0f..a6f9c577af04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
# Maintainer: xeruf <27jf at pm dot me>
_pkgname=context
-pkgname=${_pkgname}
-pkgver=2022.07.06_21.42
+pkgname=${_pkgname}-modules
+pkgver=2022.08.25_19.21
pkgrel=1
-pkgdesc='ConTeXt LMTX, the Lean and Mean TeX eXperience with Lua, MetaPost, TeX, and XML'
+pkgdesc='ConTeXt LMTX with all ConTeXt Garden modules'
arch=('x86_64')
url="https://wiki.contextgarden.net/Installation"
license=(GPL)
depends=()
-replaces=(context-bin)
+replaces=()
provides=(${_pkgname} ${_pkgname}-lmtx)
conflicts=()
optdepends=()
source=("http://lmtx.pragma-ade.nl/install-lmtx/context-linux-64.zip")
sha256sums=(SKIP)
-install=${_pkgname}.install
prepare() {
cd "${srcdir}"
+
+ # https://wiki.contextgarden.net/Modules#ConTeXt_LMTX
+ # Synchronize all modules from the ConTeXt Garden in the directory 'modules' which is created if it doesn't exist.
+ rsync -rltv --del rsync://contextgarden.net/minimals/current/modules/ modules
+ # Create the union of all modules in tex/texmf-modules (the directory is created if it doesn't exist).
+ # If you have personal modules in tex/texmf-modules, they won't be modified.
+ mkdir -p tex
+ rsync -rlt --exclude=/VERSION --del modules/*/ tex/texmf-modules
+
chmod +x install.sh
./install.sh
}