summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilly Micieli2024-01-05 11:03:15 +0100
committerWilly Micieli2024-01-05 11:03:15 +0100
commitaa53f3372795902663cf9c23fe9f76b0d2c87e33 (patch)
tree5c6ac9241ca139e81660a607a64f3a01df17fc10
parent51eae55a008ab5690b2e12c42462c96c4e23cb25 (diff)
downloadaur-aa53f3372795902663cf9c23fe9f76b0d2c87e33.tar.gz
add cargo build --release and missing rustup dep
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a137eccd484..1dd0d832197a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = continuous-testing
- pkgdesc = An rust program to test in continuous application
- pkgver = 1.0.0
- pkgrel = 5
+ pkgdesc = A continuous integration testing project
+ pkgver = 1.1.2
+ pkgrel = 1
url = https://github.com/taishingi/continuous-testing
arch = any
license = GPL3
@@ -10,10 +10,11 @@ pkgbase = continuous-testing
depends = curl
depends = fuse-overlayfs
depends = less
+ depends = rustup
depends = fd
depends = git
provides = again
- source = 1.0.0.tar.gz::https://github.com/taishingi/continuous-testing/archive/refs/tags/1.0.0.tar.gz
- sha256sums = 2d79adb5f5828dc9fdb1c8f18af2749008b06cf92ac2e18bf42b0d74f1c4a006
+ source = 1.1.2.tar.gz::https://github.com/taishingi/continuous-testing/archive/refs/tags/1.1.2.tar.gz
+ sha256sums = 797d1c07fa0b1d5ab2e48a32c83ead15f80ceeabb1b2f3e52ffe1711037b3166
pkgname = continuous-testing
diff --git a/PKGBUILD b/PKGBUILD
index 9e46e31ee2b0..7cd5b4da83a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Willy Micieli <micieli@vivaldi.net>
pkgname=continuous-testing
-pkgver=1.0.0
-pkgrel=5
-pkgdesc="An rust program to test in continuous application"
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="A continuous integration testing project"
provides=("again")
arch=('any')
url="https://github.com/taishingi/continuous-testing"
license=('GPL3')
-depends=('packer' 'libnotify' 'curl' 'fuse-overlayfs' 'less' 'fd' 'git')
+depends=('packer' 'libnotify' 'curl' 'fuse-overlayfs' 'less' 'rustup' 'fd' 'git')
source=("${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('2d79adb5f5828dc9fdb1c8f18af2749008b06cf92ac2e18bf42b0d74f1c4a006')
+sha256sums=('797d1c07fa0b1d5ab2e48a32c83ead15f80ceeabb1b2f3e52ffe1711037b3166')
package() {
cd "${pkgname}-${pkgver}"
+ cargo build --release
cargo install --path .
}