summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilly Micieli2024-01-07 13:27:58 +0100
committerWilly Micieli2024-01-07 13:27:58 +0100
commitf820ff2ac44e8aa3de0924f5b8cb90c90ea26923 (patch)
treef89c05397f2db0b9017ea77a7b421b6329ad25ac
parentaa53f3372795902663cf9c23fe9f76b0d2c87e33 (diff)
downloadaur-f820ff2ac44e8aa3de0924f5b8cb90c90ea26923.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dd0d832197a..348b06f5ef33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = continuous-testing
pkgdesc = A continuous integration testing project
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/taishingi/continuous-testing
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 7cd5b4da83a3..4478a8b1c4be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=continuous-testing
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="A continuous integration testing project"
provides=("again")
arch=('any')
@@ -12,8 +12,14 @@ depends=('packer' 'libnotify' 'curl' 'fuse-overlayfs' 'less' 'rustup' 'fd' 'git'
source=("${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('797d1c07fa0b1d5ab2e48a32c83ead15f80ceeabb1b2f3e52ffe1711037b3166')
+build() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --all-features
+}
+
package() {
cd "${pkgname}-${pkgver}"
- cargo build --release
- cargo install --path .
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
}