summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Nepogodin2024-05-25 22:31:20 +0400
committerVladislav Nepogodin2024-05-25 22:31:20 +0400
commitd52ce91b5441331f3ce676fada66e21a248ae32f (patch)
tree63909af3e93769bf54a5a4a50a1efc1e58ef7920
parent302150ecadf90fb255f9d2346bc4f93708cfb2e1 (diff)
downloadaur-d52ce91b5441331f3ce676fada66e21a248ae32f.tar.gz
🚧 exclude terminfo. provided by ncurses
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1063d344abe..040943772524 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = contour
pkgdesc = Modern C++ Terminal Emulator
pkgver = 0.4.3.6442
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/contour-terminal/contour
arch = x86_64
arch = aarch64
@@ -16,6 +16,8 @@ pkgbase = contour
makedepends = fmt
makedepends = microsoft-gsl
makedepends = catch2
+ makedepends = clang
+ makedepends = llvm
depends = harfbuzz
depends = fontconfig
depends = yaml-cpp
@@ -26,6 +28,7 @@ pkgbase = contour
depends = qt6-wayland
depends = qt6-5compat
depends = libutempter
+ optdepends = ncurses: for contour terminfo database
source = https://github.com/contour-terminal/contour/archive/refs/tags/v0.4.3.6442.tar.gz
sha512sums = f0a91fbd5abefbbac0f785bb8f454759568e3daadbad6ff1ade00fccf8b0af94f16747816598c706a698d65ce884a2e9499512942e6f22263ebc654ae6fb6879
diff --git a/PKGBUILD b/PKGBUILD
index b2f5a737b93a..389795c481f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=contour
pkgver=0.4.3.6442
-pkgrel=1
+pkgrel=2
pkgdesc="Modern C++ Terminal Emulator"
arch=(x86_64 aarch64)
url="https://github.com/contour-terminal/contour"
@@ -11,11 +11,21 @@ license=('Apache-2.0')
depends=('harfbuzz' 'fontconfig' 'yaml-cpp' 'qt6-base' 'qt6-declarative' 'qt6-multimedia'
'qt6-shadertools' 'qt6-wayland' 'qt6-5compat' 'libutempter')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'ninja' 'libxml2'
- 'python' 'range-v3' 'fmt' 'microsoft-gsl' 'catch2')
+ 'python' 'range-v3' 'fmt' 'microsoft-gsl' 'catch2'
+ 'clang' 'llvm')
+optdepends=('ncurses: for contour terminfo database')
source=("$url/archive/refs/tags/v$pkgver.tar.gz")
sha512sums=('f0a91fbd5abefbbac0f785bb8f454759568e3daadbad6ff1ade00fccf8b0af94f16747816598c706a698d65ce884a2e9499512942e6f22263ebc654ae6fb6879')
build() {
+ export AR=llvm-ar
+ export CC=clang
+ export CXX=clang++
+ export NM=llvm-nm
+ export RANLIB=llvm-ranlib
+
+ export XDG_STATE_HOME="$PWD"
+
_cpuCount=$(grep -c -w ^processor /proc/cpuinfo)
CFLAGS=${CFLAGS/-Wp,-D_GLIBCXX_ASSERTIONS}
@@ -49,6 +59,9 @@ package() {
cd "${srcdir}/build"
DESTDIR="${pkgdir}" cmake --build . --target install
+ # provided by ncurses now
+ rm -rf "${pkgdir}/usr/share/terminfo"
+
cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}