summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias2015-06-30 18:54:28 +0200
committerTobias2015-06-30 18:54:28 +0200
commitb7973b4da92cd1c407a2624096c8ab1aa5a5a80d (patch)
tree24276a825de484514ca02974f1ea284f671ca5a0
downloadaur-b7973b4da92cd1c407a2624096c8ab1aa5a5a80d.tar.gz
inital commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD64
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5dfb8d8f841c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = contour-shuttle-git
+ pkgdesc = a key input driver wrapper for the Contour-ShuttlePROv2, a Jog/Shutlle device designed for A/V editing
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/dasimmet
+ arch = x86
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ makedepends = git
+ depends = libxtst
+ depends = bash
+
+pkgname = contour-shuttle-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3078c7823c34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Your Name <dasimmet@gmail.com>
+pkgname=contour-shuttle-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="a key input driver wrapper for the Contour-ShuttlePROv2, a Jog/Shutlle device designed for A/V editing"
+arch=('x86' 'x86_64')
+url="https://github.com/dasimmet"
+license=('GPL')
+groups=()
+depends=('libxtst' 'bash')
+makedepends=('make' 'git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=()
+noextract=()
+md5sums=()
+
+_gitroot=https://github.com/dasimmet
+_gitname=ShuttlePRO
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot"/"$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+ #./autogen.sh
+ #./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/etc/udev/rules.d
+ make DESTDIR="$pkgdir/usr/" install
+ cp "99-ShuttlePRO.rules" "$pkgdir/etc/udev/rules.d/"
+ cp "example.shuttlerc" $pkgdir/etc/
+}
+
+# vim:set ts=2 sw=2 et: