summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Żok2016-04-15 13:28:46 +0200
committerTomasz Żok2016-04-15 13:28:46 +0200
commit148d53805048306e21a34c8c08951a60f7b90dde (patch)
tree15a6d31bf40f2a94b8cbb89a5096270ed6ec02a0
parenta21aa1b1c34434abbf0f4b14b0037b5901e2d2c9 (diff)
downloadaur-148d53805048306e21a34c8c08951a60f7b90dde.tar.gz
Add custom LICENSE and entry in depends array
-rw-r--r--LICENSE10
-rw-r--r--PKGBUILD12
2 files changed, 18 insertions, 4 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..30de2fdfc5ca
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,10 @@
+Copyright (c) 2016, Chuong Do
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 9043da72168b..9f785be0a041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
pkgname=contrafold
pkgver=2.02
-pkgrel=1
+pkgrel=2
pkgdesc="CONditional TRAining for RNA Secondary Structure Prediction"
arch=('i686' 'x86_64')
url="http://contra.stanford.edu/contrafold/"
-license=('BSD')
+license=('custom:BSD')
+depends=('gcc-libs')
makedepends=('gcc>=4.1.3')
source=("http://contra.stanford.edu/contrafold/${pkgname}_v${pkgver/./_}.tar.gz"
+ "LICENSE"
"LBFGS.patch"
"Utilities.patch")
md5sums=('cea66c63df835fe7f790c7f49ce83ef3'
+ 'b69f7a6ed121ab25aebc714785a84d30'
'7f5cc03bb145d7f4ff8e18ede22bbdd7'
'1edad72c52d336a0fa17862371dd60d0')
@@ -27,7 +30,8 @@ build() {
}
package() {
- cd "$pkgname/src"
install -d "$pkgdir/usr/bin/"
- install contrafold "$pkgdir/usr/bin/"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ install "$pkgname/src/contrafold" "$pkgdir/usr/bin/"
+ install LICENSE "$pkgdir/usr/share/licenses/$pkgname/"
}