summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Żok2016-04-15 11:42:10 +0200
committerTomasz Żok2016-04-15 11:42:10 +0200
commita21aa1b1c34434abbf0f4b14b0037b5901e2d2c9 (patch)
tree4e665e2d623fe8e4bcd139fba485f6bab04b575e
downloadaur-a21aa1b1c34434abbf0f4b14b0037b5901e2d2c9.tar.gz
Initial version for CONTRAfold package
-rw-r--r--.SRCINFO18
-rw-r--r--LBFGS.patch11
-rw-r--r--PKGBUILD33
-rw-r--r--Utilities.patch10
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8232313b0503
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = contrafold
+ pkgdesc = CONditional TRAining for RNA Secondary Structure Prediction
+ pkgver = 2.02
+ pkgrel = 1
+ url = http://contra.stanford.edu/contrafold/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = gcc>=4.1.3
+ source = http://contra.stanford.edu/contrafold/contrafold_v2_02.tar.gz
+ source = LBFGS.patch
+ source = Utilities.patch
+ md5sums = cea66c63df835fe7f790c7f49ce83ef3
+ md5sums = 7f5cc03bb145d7f4ff8e18ede22bbdd7
+ md5sums = 1edad72c52d336a0fa17862371dd60d0
+
+pkgname = contrafold
+
diff --git a/LBFGS.patch b/LBFGS.patch
new file mode 100644
index 000000000000..cef5d4070328
--- /dev/null
+++ b/LBFGS.patch
@@ -0,0 +1,11 @@
+--- LBFGS.ipp.orig 2016-04-15 10:46:11.527249307 +0200
++++ LBFGS.ipp 2016-04-15 10:46:21.377843414 +0200
+@@ -107,7 +107,7 @@
+
+ // perform line search, update f, and take step
+
+- Real step = DoLineSearch(x[k%2], f[k%2], g[k%2], d,
++ Real step = this->DoLineSearch(x[k%2], f[k%2], g[k%2], d,
+ x[(k+1)%2], f[(k+1)%2], g[(k+1)%2],
+ Real(0), std::min(Real(10), MAX_STEP_NORM / std::max(Real(1), Norm(d))));
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9043da72168b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
+pkgname=contrafold
+pkgver=2.02
+pkgrel=1
+pkgdesc="CONditional TRAining for RNA Secondary Structure Prediction"
+arch=('i686' 'x86_64')
+url="http://contra.stanford.edu/contrafold/"
+license=('BSD')
+makedepends=('gcc>=4.1.3')
+source=("http://contra.stanford.edu/contrafold/${pkgname}_v${pkgver/./_}.tar.gz"
+ "LBFGS.patch"
+ "Utilities.patch")
+md5sums=('cea66c63df835fe7f790c7f49ce83ef3'
+ '7f5cc03bb145d7f4ff8e18ede22bbdd7'
+ '1edad72c52d336a0fa17862371dd60d0')
+
+prepare() {
+ cd "$pkgname/src"
+ patch -p0 -i "$srcdir/LBFGS.patch"
+ patch -p0 -i "$srcdir/Utilities.patch"
+}
+
+build() {
+ cd "$pkgname/src"
+ make clean
+ make
+}
+
+package() {
+ cd "$pkgname/src"
+ install -d "$pkgdir/usr/bin/"
+ install contrafold "$pkgdir/usr/bin/"
+}
diff --git a/Utilities.patch b/Utilities.patch
new file mode 100644
index 000000000000..adde758a2356
--- /dev/null
+++ b/Utilities.patch
@@ -0,0 +1,10 @@
+--- Utilities.hpp.orig 2016-04-15 10:47:13.031387314 +0200
++++ Utilities.hpp 2016-04-15 10:47:26.417272828 +0200
+@@ -24,6 +24,7 @@
+ #include <string>
+ #include <sys/time.h>
+ #include <vector>
++#include <limits.h>
+
+ typedef unsigned char BYTE;
+ const char DIR_SEPARATOR_CHAR = '/';