summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr. Zurg Egg2023-10-27 13:53:19 -0400
committerMr. Zurg Egg2023-10-27 13:53:19 -0400
commit3823212c9764e6d884bbe83c6c8e952427d6fe08 (patch)
tree7eb67d90ac8c8a552eedcee462cb9083641ac2f7
downloadaur-3823212c9764e6d884bbe83c6c8e952427d6fe08.tar.gz
Create PKGBUILD and .SRCINFO for ConvoLV2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD40
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ac8910ab135
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = convolv2
+ pkgdesc = LV2 convolution plugin
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = https://github.com/x42/convoLV2
+ arch = x86_64
+ license = GPL2
+ depends = zita-convolver
+ source = https://github.com/x42/convoLV2/archive/refs/tags/v0.7.2.tar.gz
+ sha256sums = cdd020e284a2fc39777bfcddad67845e23d82eb25170f6e0670a49d5833d1cba
+
+pkgname = convolv2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06b8610fd67f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Zurg Egg (k1hn3trj7@mozmail.com)
+pkgname=convolv2
+pkgver=0.7.2
+pkgrel=1
+epoch=
+pkgdesc="LV2 convolution plugin"
+arch=('x86_64')
+url="https://github.com/x42/convoLV2"
+license=('GPL2')
+groups=()
+depends=('zita-convolver')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/x42/convoLV2/archive/refs/tags/v$pkgver.tar.gz")
+noextract=()
+sha256sums=('cdd020e284a2fc39777bfcddad67845e23d82eb25170f6e0670a49d5833d1cba')
+validpgpkeys=()
+
+build() {
+ cd "convoLV2-$pkgver"
+ make
+}
+
+package() {
+ cd "convoLV2-$pkgver"
+ make install PREFIX="$pkgdir/"
+}