summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpohl75892017-09-30 21:16:47 +0200
committerpohl75892017-09-30 21:31:47 +0200
commit0754b49f59a9e97f02e5db2dfa8dcd334da4a8ce (patch)
tree0ab10a01994fe9581436073aefcc02bef661fad2
downloadaur-0754b49f59a9e97f02e5db2dfa8dcd334da4a8ce.tar.gz
initial commit of arch package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--convpot.install7
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db711a720c18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = convpot
+ pkgdesc = Convert potentiostat data to a SQLite database
+ pkgver = 1.1.7
+ pkgrel = 1
+ url = https://github.com/ahpohl/convpot
+ install = convpot.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = unixodbc
+ depends = mdbtools
+ depends = sqlite3
+ optdepends = plotpot: for plotting potentiostat data
+ source = convpot-1.1.7::git+https://github.com/ahpohl/convpot.git#tag=v1.1.7
+ sha256sums = SKIP
+
+pkgname = convpot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a86ae82e7ac6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Alexander Pohl <alex at ahpohl dot com>
+pkgname=convpot
+pkgver=1.1.7
+pkgrel=1
+epoch=
+pkgdesc="Convert potentiostat data to a SQLite database"
+arch=('i686' 'x86_64')
+url="https://github.com/ahpohl/convpot"
+license=('MIT')
+groups=()
+depends=('unixodbc' 'mdbtools' 'sqlite3')
+makedepends=('cmake' 'git')
+checkdepends=()
+optdepends=('plotpot: for plotting potentiostat data')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=convpot.install
+changelog=
+source=("$pkgname-$pkgver::git+https://github.com/ahpohl/convpot.git#tag=v${pkgver}")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cp cmake/CMakeLists.txt.linux CMakeLists.txt
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/convpot.install b/convpot.install
new file mode 100644
index 000000000000..8c6e7e5a11d5
--- /dev/null
+++ b/convpot.install
@@ -0,0 +1,7 @@
+post_install() {
+cat << 'EOM'
+ ==> Convpot needs an unixODBC source for MDBTools to work
+ ==> Please add a [MDBToolsODBC] section to /etc/odbcinst.ini
+ ==> An example is given in /usr/share/convpot
+EOM
+}