summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2014-11-14 10:28:11 -0600
committerDoug Newgard2014-11-14 10:28:11 -0600
commit62f0df22c58a762ea5bc2487ad76bee7e09d08a0 (patch)
treedce7f555045b3d04534db0b35f2eb965f26bfbae
parentef31b52f62362c4ae6b6bdd75c408a29b928f729 (diff)
downloadaur-62f0df22c58a762ea5bc2487ad76bee7e09d08a0.tar.gz
Deal with new submodule
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD36
2 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec81c8f627f9..fd93c33d9c23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cool-retro-term-git
pkgdesc = A good looking terminal emulator which mimics the old cathode display
- pkgver = 0.9.r324.08ade0e
+ pkgver = 0.9.r336.16768cf
pkgrel = 1
url = https://github.com/Swordfish90/cool-retro-term
arch = i686
@@ -8,13 +8,13 @@ pkgbase = cool-retro-term-git
license = GPL
license = GPL3
makedepends = git
- depends = qt5-base
- depends = qt5-declarative
depends = qt5-quickcontrols
depends = qt5-graphicaleffects
conflicts = cool-old-term-git
replaces = cool-old-term-git
- source = cool-retro-term-git::git://github.com/Swordfish90/cool-retro-term.git
+ source = git://github.com/Swordfish90/cool-retro-term.git
+ source = git://github.com/Swordfish90/qmltermwidget.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = cool-retro-term-git
diff --git a/PKGBUILD b/PKGBUILD
index 6bf774171431..598447226757 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,50 @@
-# Maintainer: Andrey Mivrenik <gim at fastmail dot fm>
+# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+# Contributor: Andrey Mivrenik <gim at fastmail dot fm>
# Contributor: Glen Oakley <goakley123@gmail.com>
-# Contributor: Doug Newgard <scimmia at archlinux dot info>
+
pkgname=cool-retro-term-git
pkgrel=1
-pkgver=0.9.r324.08ade0e
+pkgver=0.9.r336.16768cf
pkgdesc='A good looking terminal emulator which mimics the old cathode display'
arch=('i686' 'x86_64')
url='https://github.com/Swordfish90/cool-retro-term'
license=('GPL' 'GPL3')
-depends=('qt5-base' 'qt5-declarative' 'qt5-quickcontrols' 'qt5-graphicaleffects')
+depends=('qt5-quickcontrols' 'qt5-graphicaleffects')
makedepends=('git')
replaces=('cool-old-term-git')
conflicts=('cool-old-term-git')
-source=("$pkgname::git://github.com/Swordfish90/cool-retro-term.git")
-md5sums=('SKIP')
+source=("git://github.com/Swordfish90/cool-retro-term.git"
+ "git://github.com/Swordfish90/qmltermwidget.git")
+md5sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/${pkgname%-*}"
+
+ git submodule init
+ git config submodule.qmltermwidget.url "$srcdir/qmltermwidget"
+ git submodule update
+}
pkgver () {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${pkgname%-*}"
+
local v_ver=$(awk -F '"' '/version:/ {print $2}' app/qml/ApplicationSettings.qml)
printf "$v_ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${pkgname%-*}"
+
qmake
make
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${pkgname%-*}"
+
make INSTALL_ROOT="$pkgdir" install
-}
+ install -d "$pkgdir/usr/lib/qt/qml/"
+ cp -a qmltermwidget/QMLTermWidget "$pkgdir/usr/lib/qt/qml/"
+}