summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-07 08:37:48 +0800
committerzxp198210052023-11-07 08:37:48 +0800
commitd0ead035a8bb2514978097e9eed4f1ca39e2bb72 (patch)
tree950ead701afdf5bca1db36a284d048dfef63d56b
parent56371e21a333f68f2636a5a8a3aa3635541eae69 (diff)
downloadaur-d0ead035a8bb2514978097e9eed4f1ca39e2bb72.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54f939d48fc9..8cf72d676b6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,16 +13,12 @@ pkgbase = coolterm-bin
depends = python
depends = python-psutil
depends = libunwind
- depends = glib2
- depends = gcc-libs
- depends = glibc
depends = at-spi2-core
depends = gdk-pixbuf2
depends = cairo
depends = pango
depends = libx11
conflicts = coolterm
- conflicts = coolterm-appimage
source = LICENSE
sha256sums = 3309abddebf57f96282762a63fe7937852fbad4e79e119fbe4c6aa227b197e94
source_aarch64 = coolterm-2.0.1-aarch64.zip::https://freeware.the-meiers.org/CoolTermRaspberryPi64Bit.zip
diff --git a/PKGBUILD b/PKGBUILD
index 6abf96cbdb95..c80ce3253d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,27 @@ _pkgname=CoolTerm
pkgver=2.0.1
pkgrel=4
pkgdesc="Simple GUI serial port terminal application (no terminal emulation)"
-arch=("aarch64" "armv7h" "i686" "x86_64")
+arch=(
+ "aarch64"
+ "armv7h"
+ "i686"
+ "x86_64"
+)
url="https://freeware.the-meiers.org"
license=("custom")
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'gtk3'
+ 'python'
+ 'python-psutil'
+ 'libunwind'
+ 'at-spi2-core'
+ 'gdk-pixbuf2'
+ 'cairo'
+ 'pango'
+ 'libx11'
+)
makedepends=('gendesk')
-depends=('gtk3' 'python' 'python-psutil' 'libunwind' 'glib2' 'gcc-libs' 'glibc' 'at-spi2-core' 'gdk-pixbuf2' 'cairo' 'pango' 'libx11')
source=("LICENSE")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${url}/${_pkgname}RaspberryPi64Bit.zip")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.zip::${url}/${_pkgname}RaspberryPi.zip")
@@ -22,8 +37,9 @@ sha256sums_aarch64=('c10c0b9b8432c49a9e6ae77e68941036ea5e35a3dde6713b0fc3b74ba18
sha256sums_armv7h=('258ab48d00698536585a2fcc1a0b3d5fb2ebb704776bf60d82d8c46ed4311c59')
sha256sums_i686=('fb4072c5a37744bd685e19d1fd63f649ac9824512cb1e860f24128dfc2172ab4')
sha256sums_x86_64=('5b5c2d620d20e19f8e9aeef463ee2dcc23f7c843b6da2e36da05f045d6d668ce')
-prepare() {
- gendesk -f -n --icon "${pkgname%-bin}" --categories "System;Utility" --name "${_pkgname}" --exec "${pkgname%-bin}"
+build() {
+ gendesk -q -f -n --categories "System;Utility" --name "${_pkgname}" --exec "${pkgname%-bin}"
+ find "${srcdir}/${_pkgname}/Scripting/Python/Examples" -name "*.py" -exec chmod 755 {} \;
}
package() {
install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}