summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2017-10-14 15:55:43 +0200
committermschubert2017-10-14 15:55:43 +0200
commit3a52237be41714aa6b31105cd0d53299ef14adc7 (patch)
tree820c7d0e9ebb3e01fd8c85d6df57b8664fd19a34
parent5dd3c15b716cf06ca735975b76347c6f31886685 (diff)
downloadaur-3a52237be41714aa6b31105cd0d53299ef14adc7.tar.gz
version bump 4.21.166
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--PKGBUILD.src80
3 files changed, 91 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6b21b0bbd68..3e31fcddcf19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Oct 14 13:55:13 UTC 2017
pkgbase = copasi
pkgdesc = COmplex PAthway SImulator for analysis of biochemical networks and their dynamics
- pkgver = 4.13.87
+ pkgver = 4.21.166
pkgrel = 1
url = http://www.copasi.org/
install = copasi.install
@@ -10,7 +12,7 @@ pkgbase = copasi
depends = shared-mime-info
depends = qtwebkit
depends = glu
- noextract = copasi-4.13.87.tar.gz
+ noextract = copasi-4.21.166.tar.gz
source = copasi-desktop.tar.gz
md5sums = 9582e4e3d0d1d5433dea4c48f1f5f396
diff --git a/PKGBUILD b/PKGBUILD
index 69f8f30c799a..4afe719aaac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Schubert <mschu.dev at google mail>
-
pkgname=copasi
-pkgver=4.13.87
+pkgver=4.21.166
+_pkgver=${pkgver##*.}
pkgrel=1
pkgdesc="COmplex PAthway SImulator for analysis of biochemical networks and their dynamics"
arch=('i686' 'x86_64')
@@ -12,14 +12,14 @@ source=('copasi-desktop.tar.gz')
md5sums=('9582e4e3d0d1d5433dea4c48f1f5f396')
install=copasi.install
noextract=($pkgname-$pkgver.tar.gz)
-
+_source=https://github.com/copasi/COPASI/releases/download/Build-$_pkgver
if [ "$CARCH" = "i686" ]; then
- source=("${source[@]}" $pkgname-$pkgver.tar.gz::http://www.copasi.org/static/packages/COPASI-$pkgver-Linux-32bit.tar.gz)
- md5sums=("${md5sums[@]}" '4b66ff9bfb02d7441db0031b7a22e722')
+ source=("${source[@]}" $pkgname-$pkgver.tar.gz::$_source/COPASI-$pkgver-Linux-32bit.tar.gz)
+ md5sums=("${md5sums[@]}" 'd1a6873e635e456f75119b46149b5da6')
fi
if [ "$CARCH" = "x86_64" ]; then
- source=("${source[@]}" $pkgname-$pkgver.tar.gz::http://www.copasi.org/static/packages/COPASI-$pkgver-Linux-64bit.tar.gz)
- md5sums=("${md5sums[@]}" '95bf0c46c12bc241c729e708a771ec9f')
+ source=("${source[@]}" $pkgname-$pkgver.tar.gz::$_source/COPASI-$pkgver-Linux-64bit.tar.gz)
+ md5sums=("${md5sums[@]}" '3ebcd05ce65fa6387c47bae2539c445b')
fi
package() {
diff --git a/PKGBUILD.src b/PKGBUILD.src
new file mode 100644
index 000000000000..135a6747f199
--- /dev/null
+++ b/PKGBUILD.src
@@ -0,0 +1,80 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+pkgname=copasi
+pkgver=4.21.166
+_pkgver=${pkgver##*.}
+pkgrel=1
+pkgdesc="COmplex PAthway SImulator for analysis of biochemical networks and their dynamics"
+arch=('i686' 'x86_64')
+url="http://www.copasi.org/"
+license=('Artistic 2.0')
+makedepends=('cmake' 'git' 'python')
+depends=('cppunit' 'expat' 'lapack' 'libnuml' 'qtwebkit' 'qwt5' 'qwtplot3d')
+optdepends=('python')
+source=("copasi-desktop.tar.gz"
+ "git+https://github.com/copasi/copasi-dependencies.git"
+ "https://github.com/copasi/COPASI/releases/download/Build-$_pkgver/COPASI-$pkgver-Source.tar.gz")
+install=copasi.install
+md5sums=('9582e4e3d0d1d5433dea4c48f1f5f396'
+ 'SKIP'
+ '99ea39c37f2657c6804711fabd4d34da')
+
+build() {
+ # QtMmlWidget is required even if we deactivate it
+ # raptor in extra is not compatible
+ # libsbml needs 'render' package, is not in current version
+ cd "$srcdir"/copasi-dependencies
+ ./createLinux.sh MML raptor libSBML libCombine
+
+ mkdir -p "$srcdir"/copasi && cd "$srcdir"/copasi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCOPASI_INSTALL_C_API=ON \
+ -DRAPTOR_INCLUDE_DIR="$srcdir"/copasi-dependencies/bin/include \
+ -DRAPTOR_LIBRARY="$srcdir"/copasi-dependencies/bin/lib/libraptor.a \
+ -DMML_INCLUDE_DIR="$srcdir"/copasi-dependencies/bin/include \
+ -DMML_LIBRARY="$srcdir"/copasi-dependencies/bin/lib/libmml.a \
+ -DLIBSBML_INCLUDE_DIR="$srcdir"/copasi-dependencies/bin/include \
+ -DLIBSBML_LIBRARY="$srcdir"/copasi-dependencies/bin/lib/libsbml-static.a \
+ -DQWT_INCLUDE_DIR=/usr/include/qwt5 \
+ -DQWT_LIBRARY=/usr/lib/libqwt5.so \
+ -DENABLE_SBW_INTEGRATION=OFF \
+ -DENABLE_PYTHON=ON \
+ ../COPASI-$pkgver-Source
+
+# enable bindings:
+# -DENABLE_CSHARP=ON \
+# -DENABLE_JAVA=ON \
+# -DENABLE_PERL=ON \
+# -DENABLE_OCTAVE=ON \
+# -DENABLE_R=ON \
+
+ make
+}
+
+package() {
+ cd "$srcdir"/copasi
+ make DESTDIR="$pkgdir" install
+
+# DESTDIR="$pkgdir" cmake \
+# -DCMAKE_INSTALL_PREFIX=/usr \
+# -P "$srcdir/$pkgname-master"/cmake_install.cmake
+
+# cd "$srcdir"
+# tar -xf $pkgname-$pkgver.tar.gz --strip=1
+#
+# # install program files
+# install -d "$pkgdir"/usr/{bin,share}
+# install -m755 bin/* "$pkgdir/usr/bin"
+# cp -R share/$pkgname "$pkgdir/usr/share/"
+#
+ # desktop integration
+ cd "$srcdir/$pkgname-desktop"
+ install -Dm755 copasi.sh "$pkgdir/etc/profile.d/copasi.sh"
+ install -Dm644 copasi.desktop "$pkgdir/usr/share/applications/copasi.desktop"
+ install -Dm644 copasi.xml "$pkgdir/usr/share/mime/packages/copasi.xml"
+ install -d "$pkgdir/usr/share/icons/hicolor"
+ cp -R icons/* "$pkgdir/usr/share/icons/hicolor/"
+ # copasi starts CopasiUI after setting COPASIDIR environment variable
+ # useful for launching COPASI using the menu entry
+ install -Dm755 copasi "$pkgdir/usr/bin/copasi"
+}