summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2015-10-21 22:04:47 -0700
committerKyle Manna2015-10-21 22:04:47 -0700
commit6231e613a995d6c4471d1e3e289522e32622f54e (patch)
tree388c19956618a33f9f287ded298c81217865f10f
downloadaur-6231e613a995d6c4471d1e3e289522e32622f54e.tar.gz
Initial commit: v1.4.0
* Basic build.
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD43
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f00e3b2873b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = copay
+ pkgdesc = Copay Bitcoin Wallet
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://copay.io
+ arch = x86_64
+ license = MIT
+ options = !strip
+ source_x86_64 = https://github.com/bitpay/copay/releases/download/v1.4.0/copay-linux64.zip
+ sha512sums_x86_64 = b2cf1bc3f5af2f171447037d8aa5063f9cdc26443a06c7dd11a1ea2f2b8f5fa29e9fad024b95549cc8434674bcfe566944465a1b821773a2ea31a57116c5dd13
+
+pkgname = copay
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9bd67ce83c8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.sign
+*.zip
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb01af97f94a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Author: Kyle Manna <kyle(at)kylemanna(dot)com>
+#
+# Upstream: https://github.com/bitpay/copay
+
+pkgname=copay
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Copay Bitcoin Wallet"
+#arch=('i686' 'x86_64')
+arch=('x86_64')
+url="https://copay.io"
+license=('MIT')
+depends=('')
+
+# For some reason, stripping the massive copay binary breaks the app
+options=('!strip')
+
+source_x86_64=("https://github.com/bitpay/copay/releases/download/v${pkgver}/copay-linux64.zip")
+#source_i686=("https://github.com/bitpay/copay/releases/download/v${pkgver}/copay-linux32.zip")
+
+sha512sums_x86_64=('b2cf1bc3f5af2f171447037d8aa5063f9cdc26443a06c7dd11a1ea2f2b8f5fa29e9fad024b95549cc8434674bcfe566944465a1b821773a2ea31a57116c5dd13')
+#sha512sums_i686=('')
+
+# TODO: add signature files
+# TODO: test 32 bit build (maybe)
+
+package() {
+
+ # Prep destination
+ mkdir -p ${pkgdir}/opt/copay
+ cd ${pkgdir}/opt/copay
+
+ # Unzip the binary package
+ unzip ${startdir}/copay-linux*.zip
+
+ # Remove arch suffix
+ mv copay-linux*/* .
+ rmdir copay-linux*
+
+ # Symlink in to the default PATH
+ mkdir -p ${pkgdir}/usr/bin
+ ln -s /opt/copay/copay ${pkgdir}/usr/bin/copay
+}