summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul TREHIOU2016-08-08 11:12:10 +0200
committerKyle Manna2016-08-08 12:44:42 -0700
commitc09ccbfb33ce92531665c9cee778b0f8c8c08471 (patch)
tree7d34f3ccc08963df71c7e634640ec035b72fc949
parent32456e41c52bc182236127cf5f4bf48e0b8770c5 (diff)
downloadaur-c09ccbfb33ce92531665c9cee778b0f8c8c08471.tar.gz
add desktop entry
-rw-r--r--PKGBUILD8
-rw-r--r--copay.desktop25
2 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index deb5c1e96478..cb8c77c70e41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,10 @@ depends=('')
# For some reason, stripping the massive copay binary breaks the app
options=('!strip')
+source=('copay.desktop')
+
+md5sums=('e05610d1b08a2c688efccf9d687b8b92')
+
source_x86_64=("https://github.com/bitpay/copay/releases/download/v${pkgver}/Copay-linux.zip"
"https://github.com/bitpay/copay/releases/download/v${pkgver}/Copay-linux.zip.sig"
)
@@ -46,4 +50,8 @@ package() {
# Symlink in to the default PATH
mkdir -p ${pkgdir}/usr/bin
ln -s /opt/copay/Copay ${pkgdir}/usr/bin/copay
+
+ # Create desktop icon
+ install -Dm644 "$srcdir"/copay.desktop "$pkgdir/usr/share/applications/copay.desktop"
+ install -Dm644 "$srcdir"/copay-linux/icon-256.png "$pkgdir/usr/share/pixmaps/copay.png"
}
diff --git a/copay.desktop b/copay.desktop
new file mode 100644
index 000000000000..7727a78d2078
--- /dev/null
+++ b/copay.desktop
@@ -0,0 +1,25 @@
+[Desktop Entry]
+
+# The type as listed above
+Type=Application
+
+# The version of the desktop entry specification to which this file complies
+Version=2.4.0
+
+# The name of the application
+Name=Copay
+
+# A comment which can/will be used as a tooltip
+Comment=Copay Bitcoin Wallet
+
+# The executable of the application.
+Exec=copay
+
+# The name of the icon that will be used to display this entry
+Icon=copay
+
+# Describes whether this application needs to be run in a terminal or not
+Terminal=false
+
+# Describes the categories in which this entry should be shown
+Categories=Finance;P2P