summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2017-06-09 07:47:44 -0700
committerKyle Manna2017-06-09 07:56:32 -0700
commitd39b3fad8ca7c49372a2f2789024533ecc8803c3 (patch)
tree5e7bfa33487a0679c677f45dd9b3db2ea48b6f11
parent955563870644373a9ef22b3999fdbdf953f593d9 (diff)
downloadaur-d39b3fad8ca7c49372a2f2789024533ecc8803c3.tar.gz
release: v3.4.0 and change to source build
* Follow upstream v3.4.0 release * Change to source build due to binary build quality issues [0] [0] https://github.com/bitpay/copay/issues/6204
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD45
2 files changed, 33 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 427290da1d68..b554e1c5e620 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
# Generated by mksrcinfo v8
-# Wed May 24 18:39:15 UTC 2017
+# Fri Jun 9 14:47:39 UTC 2017
pkgbase = copay
pkgdesc = Copay Bitcoin Wallet
- pkgver = 3.2.0
+ pkgver = 3.4.0
pkgrel = 1
url = https://copay.io
arch = x86_64
license = MIT
+ depends = npm
options = !strip
source = copay.desktop
md5sums = e05610d1b08a2c688efccf9d687b8b92
- source_x86_64 = copay-3.2.0.zip::https://github.com/bitpay/copay/releases/download/v3.2.0/Copay-linux.zip
- source_x86_64 = copay-3.2.0.zip.sig::https://github.com/bitpay/copay/releases/download/v3.2.0/Copay-linux.zip.sig
- md5sums_x86_64 = 870ecc09ab61c89d24f52b8c8faf3895
+ source_x86_64 = copay-3.4.0::git+https://github.com/bitpay/copay.git#tag=v3.4.0
md5sums_x86_64 = SKIP
pkgname = copay
diff --git a/PKGBUILD b/PKGBUILD
index 4305418eefe1..bee88cfb131a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Author: Kyle Manna <kyle(at)kylemanna(dot)com>
#
# Upstream: https://github.com/bitpay/copay
+#
+# Signed upstream binaries dropped in favor of git build due to quality issues
+# highlighted at https://github.com/bitpay/copay/issues/6204
pkgname=copay
-pkgver=3.2.0
+pkgver=3.4.0
pkgrel=1
pkgdesc="Copay Bitcoin Wallet"
-#arch=('i686' 'x86_64')
arch=('x86_64')
url="https://copay.io"
license=('MIT')
-depends=('')
+depends=('npm')
# For some reason, stripping the massive copay binary breaks the app
options=('!strip')
@@ -18,29 +20,39 @@ options=('!strip')
source=('copay.desktop')
md5sums=('e05610d1b08a2c688efccf9d687b8b92')
-md5sums_x86_64=('870ecc09ab61c89d24f52b8c8faf3895'
- 'SKIP')
-
-source_x86_64=("${pkgname}-${pkgver}.zip::https://github.com/bitpay/copay/releases/download/v${pkgver}/Copay-linux.zip"
- "${pkgname}-${pkgver}.zip.sig::https://github.com/bitpay/copay/releases/download/v${pkgver}/Copay-linux.zip.sig"
- )
+md5sums_x86_64=('SKIP')
+# Ideally the upstream git repo tags would signed, or the repo source snapshots were signed.
+# Would be nice if anything was signed and worked.
+# TODO: Try to verify the git tag we are about to build
+source_x86_64=("${pkgname}-${pkgver}::git+https://github.com/bitpay/copay.git#tag=v${pkgver}")
+# Previously used for signed binary releases
# gpg --recv-keys 9D17E656BB3B6163AE9D71725CD600A61112CFA1
-validpgpkeys=('9D17E656BB3B6163AE9D71725CD600A61112CFA1')
+#validpgpkeys=('9D17E656BB3B6163AE9D71725CD600A61112CFA1')
-# TODO: test 32 bit build (maybe)
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
-package() {
+ npm run clean-all
+ npm run apply:copay
+ npm run build:desktop
+}
+#
+# TODO: Placing the entire node-webkit build in /opt feels dirty if we just
+# built the package, but scattering it around /usr feels worse. Is there
+# a recommended psuedo-webapps convention?
+#
+package() {
# Prep destination
mkdir -p ${pkgdir}/opt/copay
cd ${pkgdir}/opt/copay
# Unzip the binary package
- unzip ${startdir}/${pkgname}-${pkgver}.zip
+ unzip "${srcdir}/${pkgname}-${pkgver}/webkitbuilds/Copay-linux.zip"
- # Remove arch suffix
+ # Remove arch directory
mv Copay-linux/* .
rmdir Copay-linux
@@ -52,6 +64,7 @@ package() {
ln -s /opt/copay/Copay ${pkgdir}/usr/bin/copay
# Create desktop icon
- install -Dm644 "$srcdir"/copay.desktop "$pkgdir/usr/share/applications/copay.desktop"
- install -Dm644 "$srcdir"/Copay-linux/512x512.png "$pkgdir/usr/share/pixmaps/copay.png"
+ mkdir -p "${pkgdir}/usr/share/applications" "${pkgdir}/usr/share/pixmaps"
+ ln -s "${pkgdir}/opt/copay/copay.desktop" "$pkgdir/usr/share/applications/copay.desktop"
+ ln -s "${pkgdir}/opt/copay/512x512.png" "$pkgdir/usr/share/pixmaps/copay.png"
}