summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-01-22 10:28:09 -0300
committerDaniel Bermond2022-01-22 10:28:09 -0300
commita18e6fc0628d69fee00fc05a643db6235f97977b (patch)
tree205878f016188d66610918a4a6583fdec8d6dd3d
parent422ae66b73fd53c769e67244218c54cb09901103 (diff)
downloadaur-a18e6fc0628d69fee00fc05a643db6235f97977b.tar.gz
Update to version 1.7.3
-rw-r--r--.SRCINFO12
-rw-r--r--010-copperspice-fix-cmake-include-dirs.patch6
-rw-r--r--PKGBUILD9
3 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 551dbb747216..f4187c4f202d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = copperspice
pkgdesc = Libraries for developing cross platform software applications in C++
- pkgver = 1.7.1
- pkgrel = 2
+ pkgver = 1.7.3
+ pkgrel = 1
url = https://www.copperspice.com/
arch = x86_64
license = LGPL2.1
@@ -39,10 +39,10 @@ pkgbase = copperspice
depends = zlib
optdepends = mariadb-libs: for MySQL database support
optdepends = postgresql-libs: for PostgreSQL database support
- source = https://github.com/copperspice/copperspice/archive/cs-1.7.1/copperspice-1.7.1.tar.gz
+ options = !lto
+ source = https://github.com/copperspice/copperspice/archive/cs-1.7.3/copperspice-1.7.3.tar.gz
source = 010-copperspice-fix-cmake-include-dirs.patch
- sha256sums = 2e74c809f6e9bffbe53f2f758b280781f6905631d9647717b47bc9202dba0d41
- sha256sums = 14c52854ed1d92430a4b4ce6dd967f86141cc3352784b2396f786575bac0bdd0
+ sha256sums = c1c1318f04aae0e4af10fffa6d20267768c2b1acc4c339f41609629584f81c39
+ sha256sums = ad8764d825950dcb98a1088a2f778d449c39e33a3c2edf037a45c30c341045d4
pkgname = copperspice
-
diff --git a/010-copperspice-fix-cmake-include-dirs.patch b/010-copperspice-fix-cmake-include-dirs.patch
index 5f2a08fa33cf..17434930dec0 100644
--- a/010-copperspice-fix-cmake-include-dirs.patch
+++ b/010-copperspice-fix-cmake-include-dirs.patch
@@ -1,6 +1,6 @@
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
-@@ -154,8 +154,8 @@ endif()
+@@ -154,8 +154,8 @@ target_sources(CsCore
target_include_directories(CsCore
PUBLIC
@@ -10,10 +10,10 @@
+ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}/QtCore>
)
- set_target_properties(CsCore
+ if(MSVC)
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
-@@ -175,7 +175,7 @@ target_sources(CsGui
+@@ -179,7 +179,7 @@ target_sources(CsGui
target_include_directories(CsGui
PUBLIC
diff --git a/PKGBUILD b/PKGBUILD
index 16c4016edec4..44b62b17496b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=copperspice
-pkgver=1.7.1
-pkgrel=2
+pkgver=1.7.3
+pkgrel=1
pkgdesc='Libraries for developing cross platform software applications in C++'
arch=('x86_64')
url='https://www.copperspice.com/'
@@ -16,10 +16,11 @@ optdepends=('mariadb-libs: for MySQL database support'
makedepends=('cmake' 'alsa-lib' 'mariadb-libs' 'postgresql' 'postgresql-libs'
'libxcursor' 'libxext' 'libxfixes' 'libxinerama' 'libxrandr'
'libxrender' 'libxml2')
+options=('!lto')
source=("https://github.com/copperspice/copperspice/archive/cs-${pkgver}/${pkgname}-${pkgver}.tar.gz"
'010-copperspice-fix-cmake-include-dirs.patch')
-sha256sums=('2e74c809f6e9bffbe53f2f758b280781f6905631d9647717b47bc9202dba0d41'
- '14c52854ed1d92430a4b4ce6dd967f86141cc3352784b2396f786575bac0bdd0')
+sha256sums=('c1c1318f04aae0e4af10fffa6d20267768c2b1acc4c339f41609629584f81c39'
+ 'ad8764d825950dcb98a1088a2f778d449c39e33a3c2edf037a45c30c341045d4')
prepare() {
patch -d "copperspice-cs-${pkgver}" -Np1 -i "${srcdir}/010-copperspice-fix-cmake-include-dirs.patch"