summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-01-22 10:28:40 -0300
committerDaniel Bermond2022-01-22 10:28:40 -0300
commit682b8228fc3b3906a4b3d0c1d464bcab27143049 (patch)
tree620d7fd62775b9dcdedc8ac1198d09c08477bc80
parent84dc37f7fd1bfce09ee2cdc81a98cbcfa6d3d2b2 (diff)
downloadaur-682b8228fc3b3906a4b3d0c1d464bcab27143049.tar.gz
Disable lto to fix build. Refresh patch.
-rw-r--r--.SRCINFO6
-rw-r--r--010-copperspice-fix-cmake-include-dirs.patch6
-rw-r--r--PKGBUILD5
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44d33b59ec5d..e8bb976029e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = copperspice-git
pkgdesc = Libraries for developing cross platform software applications in C++ (git version)
- pkgver = 1.7.1.r7.g32a9749a2
+ pkgver = 1.7.3.r0.gcef05d043
pkgrel = 1
url = https://www.copperspice.com/
arch = x86_64
@@ -42,10 +42,10 @@ pkgbase = copperspice-git
optdepends = postgresql-libs: for PostgreSQL database support
provides = copperspice
conflicts = copperspice
+ options = !lto
source = git+https://github.com/copperspice/copperspice.git
source = 010-copperspice-fix-cmake-include-dirs.patch
sha256sums = SKIP
- sha256sums = f1f5f5b18d93173cdd78c9fac944a31feb7280efcca3d3533cbdee90266249fa
+ sha256sums = ad8764d825950dcb98a1088a2f778d449c39e33a3c2edf037a45c30c341045d4
pkgname = copperspice-git
-
diff --git a/010-copperspice-fix-cmake-include-dirs.patch b/010-copperspice-fix-cmake-include-dirs.patch
index 7820d9bf15fc..17434930dec0 100644
--- a/010-copperspice-fix-cmake-include-dirs.patch
+++ b/010-copperspice-fix-cmake-include-dirs.patch
@@ -1,6 +1,6 @@
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
-@@ -156,8 +156,8 @@ endif()
+@@ -154,8 +154,8 @@ target_sources(CsCore
target_include_directories(CsCore
PUBLIC
@@ -10,10 +10,10 @@
+ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}/QtCore>
)
- set_target_properties(CsCore
+ if(MSVC)
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
-@@ -175,7 +175,7 @@ target_sources(CsGui
+@@ -179,7 +179,7 @@ target_sources(CsGui
target_include_directories(CsGui
PUBLIC
diff --git a/PKGBUILD b/PKGBUILD
index e4e172150d08..bbf8fde8901e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=copperspice-git
-pkgver=1.7.1.r7.g32a9749a2
+pkgver=1.7.3.r0.gcef05d043
pkgrel=1
pkgdesc='Libraries for developing cross platform software applications in C++ (git version)'
arch=('x86_64')
@@ -18,10 +18,11 @@ makedepends=('git' 'cmake' 'alsa-lib' 'mariadb-libs' 'postgresql' 'postgresql-li
'libxrender' 'libxml2')
provides=('copperspice')
conflicts=('copperspice')
+options=('!lto')
source=('git+https://github.com/copperspice/copperspice.git'
'010-copperspice-fix-cmake-include-dirs.patch')
sha256sums=('SKIP'
- 'f1f5f5b18d93173cdd78c9fac944a31feb7280efcca3d3533cbdee90266249fa')
+ 'ad8764d825950dcb98a1088a2f778d449c39e33a3c2edf037a45c30c341045d4')
prepare() {
patch -d copperspice -Np1 -i "${srcdir}/010-copperspice-fix-cmake-include-dirs.patch"