summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2015-07-09 07:58:31 +1000
committerJustin Dray2015-07-09 08:02:14 +1000
commit8d186c08b24d7bd95714a53977f35de6abb4c2ed (patch)
tree55bafb99dde6d5e7738ac6459823733b4766d85b
downloadaur-8d186c08b24d7bd95714a53977f35de6abb4c2ed.tar.gz
Update to: 3.2.01.0481-1
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD71
-rw-r--r--TERMS144
-rw-r--r--copy-agent.desktop10
-rw-r--r--copy-agent.install11
-rw-r--r--copy-agent.pngbin0 -> 12468 bytes
-rw-r--r--copy-agent.service13
-rw-r--r--copy-console.service13
-rwxr-xr-xlaunch.sh4
10 files changed, 311 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..996c75eb4482
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = copy-agent
+ pkgdesc = Copy.com sync agent
+ pkgver = 3.2.01.0481
+ pkgrel = 1
+ url = http://www.copy.com
+ install = copy-agent.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = custom
+ depends = fuse
+ depends = desktop-file-utils
+ optdepends = qt4: GUI support
+ optdepends = libindicator-gtk2: indicator support
+ options = !strip
+ options = !upx
+ source = https://copy.com/install/linux/Copy.tgz
+ source = copy-agent.desktop
+ source = copy-agent.png
+ source = copy-agent.service
+ source = copy-console.service
+ source = launch.sh
+ source = TERMS
+ sha256sums = f33c0297c2d8f7e90ec481beed88a918446a87507c9ea29f8feae21a4e85f72e
+ sha256sums = ef1767720b5e5eff6567e537f3fed1c1d7da17e4f4248479816cab924f62e431
+ sha256sums = b69bc2f8b4315a43d3b60b11ec9c226c2060d14ac4d5702140260961c74620cb
+ sha256sums = f9a460a12e5ee382b9d2d435028b46e3e289c0b49e4fd382d67052f297531c4a
+ sha256sums = b0f44d8e7144b2b00b4494c14795dde87f1db9bd7947b9be2986f393562f8a98
+ sha256sums = 059995cd96ae09d92681063ffd6d5ee603fa1a4b9fdae9b315494d5becb203c6
+ sha256sums = c328ddfce46fb5577b1d3d4f67258aa1caee671214e335d802cdc9a065a1595a
+
+pkgname = copy-agent
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..18aa15790de4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+*
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.desktop
+!*.install
+!*.service
+!*.sh
+!*.conf
+!.gitignore
+!copy-agent.png
+!TERMS
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a799158162c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Wei-Ning Huang <aitjcize@gmail.com>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Tom < tomgparchaur at gmail dot com >
+
+pkgname=copy-agent
+pkgver=3.2.01.0481
+pkgrel=1
+pkgdesc="Copy.com sync agent"
+arch=("i686" "x86_64" "armv6h")
+url="http://www.copy.com"
+license=(custom)
+depends=("fuse" "desktop-file-utils")
+optdepends=("qt4: GUI support"
+ "libindicator-gtk2: indicator support")
+options=('!strip' '!upx')
+install=$pkgname.install
+sha256sums=('f33c0297c2d8f7e90ec481beed88a918446a87507c9ea29f8feae21a4e85f72e'
+ 'ef1767720b5e5eff6567e537f3fed1c1d7da17e4f4248479816cab924f62e431'
+ 'b69bc2f8b4315a43d3b60b11ec9c226c2060d14ac4d5702140260961c74620cb'
+ 'f9a460a12e5ee382b9d2d435028b46e3e289c0b49e4fd382d67052f297531c4a'
+ 'b0f44d8e7144b2b00b4494c14795dde87f1db9bd7947b9be2986f393562f8a98'
+ '059995cd96ae09d92681063ffd6d5ee603fa1a4b9fdae9b315494d5becb203c6'
+ 'c328ddfce46fb5577b1d3d4f67258aa1caee671214e335d802cdc9a065a1595a')
+
+source=(https://copy.com/install/linux/Copy.tgz
+ $pkgname.desktop
+ $pkgname.png
+ $pkgname.service
+ copy-console.service
+ launch.sh
+ TERMS)
+
+package() {
+ cd ${srcdir}
+ desktop-file-install $pkgname.desktop --dir "$pkgdir/usr/share/applications/"
+ install -Dm0644 $pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm0644 $pkgname.service "$pkgdir/usr/lib/systemd/user/$pkgname.service"
+ install -Dm0644 copy-console.service "$pkgdir/usr/lib/systemd/user/copy-console.service"
+ install -Dm0644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 TERMS "$pkgdir/usr/share/licenses/$pkgname/TERMS"
+
+ if [ "$CARCH" == "x86_64" ]; then
+ cd copy/x86_64
+ elif [ "$CARCH" == "i686" ]; then
+ cd copy/x86
+ else
+ cd copy/armv6h
+ fi
+
+ for i in lib{AgentSync,Brt,CloudSync}.so; do
+ install -Dm755 $i "$pkgdir/opt/copy/$i"
+ done
+
+ if [ "$CARCH" != "armv6h" ]; then
+ install -Dm755 libGui.so "$pkgdir/opt/copy/libGui.so"
+ fi
+
+ for i in ca-bundle.crt copyext.rcc; do
+ install -Dm755 $i "$pkgdir/opt/copy/$i"
+ done
+
+ mkdir -p $pkgdir/usr/bin
+ for i in Copy{Agent,Cmd,Console}; do
+ install -Dm755 $i "$pkgdir/opt/copy/$i"
+ install -Dm755 $srcdir/launch.sh $pkgdir/usr/bin/$i
+ done
+
+ install -Dm755 libnautilus-copy.so "$pkgdir/usr/lib/nautilus/extensions-3.0/libnautilus-copy.so"
+ install -Dm755 libcaja-copy.so "$pkgdir/usr/lib/caja/extensions-2.0/libcaja-copy.so"
+}
diff --git a/TERMS b/TERMS
new file mode 100644
index 000000000000..1a80bbce87f2
--- /dev/null
+++ b/TERMS
@@ -0,0 +1,144 @@
+Barracuda Networks Terms of Service
+Last Modified: February 2013
+
+The Copy Terms of Service (the "Terms" or "Agreement") is a legal agreement between you, either an individual or a single legal entity ("You" or "you" or "Your" or "your"), and Barracuda Networks, Inc. for the Copy service ("Copy" or "Product" or "we" or "our"). These Terms govern your use of Copy, including any updates and accompanying written documentation.
+
+Your use of the Copy constitutes your binding legal agreement to these Terms, which are subject to change at any time by Barracuda Networks. If you are not legally able to be bound by these Terms, your use of Copy is prohibited.
+
+You acknowledge and agree that Copy may occasionally contact you via email. Please refer to Copy’s Privacy Policy, (https://www.copy.com/about/privacy) for information about how we use, transfer and share information we collect and you store within Copy.
+
+Your Data and Privacy
+
+When you use the Product, you agree that Copy may duplicate and store your data, information, files and folders in accordance with Copy’s policies and these Terms. As between You and Copy, all information You provide to Copy remains your property.
+
+We may also need to share your data, information, files and folders with third parties who assist us in providing the service. You hereby consent to such sharing. In addition, Copy may contain links to third party websites or resources. Your use of the third party materials is governed by their terms and not this Agreement. We are not responsible for or endorse these third parties.
+
+You are responsible for maintaining and protecting your data in Copy and Copy is not responsible for any loss or corruption to your files or information or for backing up such information.
+
+Copy is not intended for use by persons under the age of 13 years old. By accepting these terms you represent that you are at least 13 years old.
+
+Accounts, Passwords and Security
+
+You must be a registered user to access the Product. Individual users must register using their name and entity users must register under the legal name of their entity. You are responsible for keeping your password private and secure, and are prohibited from sharing your login and password with others. You will be solely responsible and liable for any activity that occurs under your user name.
+
+Acceptable Use and Conduct
+
+You are solely responsible for your conduct and your data content uploaded or otherwise placed into Copy. We are not responsible for the legality and appropriateness of information in Copy which you may be able to access or view through your use. You agree to indemnify, defend, and hold harmless Copy and its suppliers from any and all loss, cost, liability, and expense arising from or related to your data, your use of the Products, or your violation of these terms.
+
+The Products are made available to you only for your personal or internal business use, which use must be in compliance with all applicable Copy policies, laws, rules and regulations and must not infringe or violate third party rights. You may not make commercial use of the Products, including but not limited to selling, licensing, providing services, or distributing the Products to any third party.
+
+Any unauthorized use of any Copy computer system is a violation of these Terms and may also violate certain federal and state laws. Such violations may subject the unauthorized user and his or her agents to civil and criminal penalties. Copy may immediate remove any content or data, or suspend or cancel accounts if it becomes aware of any misuse or illegal actions associated with an account or user, without prior notice to You.
+
+You must use Copy responsibly and in a way not interfere with the use, privacy or rights of others. When using Copy, you must not, and must not attempt to, use the services to do any of the following things.
+
+copy or upload files or information unless you have a legal right to the files or information
+probe, scan, or test the vulnerability of any system, or attempt to circumvent any security or authentication measures;
+access, tamper with, or use non-public areas of Copy or attempt to access or search Copy through nonpublic interfaces
+attempt to disrupt any user or network by sending a virus, malware, overloading, flooding, spamming, or mail-bombing
+send unsolicited communications, promotions or advertisements, or spam;
+send altered, deceptive or false source-identifying information, including "spoofing" or "phishing";
+publish anything that is fraudulent, misleading, or infringes another's rights misrepresent yourself or affiliation with an entity;
+publish or share materials that are offensive, defamatory, or unlawfully;
+Changes Copy Products and Terms
+
+Copy reserves the right at any time to modify, suspend, or discontinue providing the Product or any part thereof in its sole discretion with or without notice.
+
+Copy reserves the right at any time to modify these Terms in its sole discretion, without liability to you. This Agreement, as amended, will be effective upon use of the Copy Products for all existing users immediately after posting of any amended terms on the Copy.com website. You agree to be bound by this Agreement, as modified. If you do not agree to any changes to the Terms, you must stop using Copy and terminate your account immediately.
+
+Please review the most current version of this Agreement from time to time, located at https://www.copy.com/policies (or such successor URL as Copy may provide), so that you will be apprised of any changes.
+
+License to Copy
+
+Subject to the terms and conditions of this Agreement, Copy grants you a non-exclusive, non- transferable, non-sublicensable limited and revocable license to use the Product (including but not limited to the client software) and to use the Copy Products for the sole and exclusive purposes of your personal or internal business purposes. Certain third party code may be provided with, or contained in, the Product. The third-party license terms accompanying such code, and not the terms of this Agreement, will govern your use of such code. Copy reserves all other rights to its Products.
+
+The Products and their structure, organization, source code, and documentation contain valuable trade secrets of Copy and its licensors, and accordingly you agree not to (and agree not to allow third parties to) (1) sublicense, transfer, or distribute any aspect of the Products or any derivative thereof to any third party, (2) modify, adapt, translate, or prepare derivative works from the Product, (3) decompile, reverse engineer, disassemble or otherwise attempt to derive source code from the Product, (4) extract portions of the software’s files for use in other applications, or (5) remove, obscure, or alter Copy’s or any third party’s trademarks or copyright or other proprietary rights notices affixed to or contained within or accessed in conjunction with or through the Products.
+
+Renewals
+
+You agree that Copy shall have the right to automatically and without notice renew your license to continue to use the Products upon expiration of your license period.. You agree that if you elect to not permit Copy the right to automatically renew your license to use the Products or maintain your credit card information on file, then Copy may terminate your license.
+
+Intellectual Property
+
+You acknowledge that Copy or third parties own all right, title and interest in and to the computer source code related to the Product, portions thereof, or software or content provided through or in conjunction with the Product, including without limitation all intellectual property rights. Except for the license granted in this Section, all rights in and to the Products are reserved, and no implied licenses are granted by Copy.
+
+If you have comments on the Products or ideas on how to improve them, please visit http://copy.com/feedback. Please note that by doing so, you also grant Copy a perpetual, fully paid, royalty-free, irrevocable, transferable license, with right of sublicense, to use and incorporate your ideas or comments into the Products (or third party software, content, or services), and to otherwise exploit your ideas and comments, in each case without further compensation.
+
+Copyright
+
+When using Copy, you must respect the intellectual property rights of others. We will respond to any notice of alleged copyright infringement if they comply with the law and are properly reported to use through our DMCA process (https://www.copy.com/about/dmca). We reserve the right to delete or disable content alleged to infringe and our designated agent for alleged infringement is:
+
+Copyright Agent
+Barracuda Networks, Inc.
+3175 S. Winchester Blvd
+Campbell, CA 95007
+copyright@barracuda.com
+
+Pricing Terms and Conditions
+
+Upgraded Accounts
+
+Copy offers you the option of increasing your account storage space beyond 5 GB for a fee. By doing so, your account will be converted to a Premium Account and will not be subject to some of the restrictions placed on Free Accounts as described below.
+
+Copy accepts credit cards and will automatically charge your credit card monthly or yearly, depending upon which Premium Account you select. If any fee is not paid in a timely manner, or Copy is unable to process your transaction using the credit card information provided, Copy reserves the right to revoke access to your Copy account and reserves the right to use our discretion to delete some or all of Your data so as to reduce your storage space to below 2 GB, and to convert your Premium Account to a Free Account (which is subject to the restrictions described below).
+
+Billing
+
+The fees for your Upgraded Account will be billed from the date you elect, or convert to, a Upgraded Account and on each monthly or yearly renewal thereafter unless and until you cancel your account. Click on the link on your "Account" page to see the commencement date for your next renewal period. Copy will automatically bill your credit card each month or year on the anniversary of the commencement of your Upgraded Account. You acknowledge that the amount billed each month or year may vary for reasons that include, differing amounts due to promotional offers, differing amounts due to changes in your account, or changes in the amount of applicable sales tax, and you authorize us to charge your credit card for such varying amounts. Copy may also periodically authorize your credit card in anticipation of account or related charges. All fees and charges are noncancelable and nonrefundable and no credits will be given for partially used periods.
+
+Should you elect to increase your Upgraded Account to a larger amount of storage space, the commencement date for your next renewal period will be reset and you will be billed for the first month or year of the upgraded level of service on a pro-rata basis.
+
+Copy may change the fees and charges in effect, or add new fees and charges from time to time, but we will give you advance notice of these changes by email or on the website. If you want to use a different credit card or if there is a change in your credit card validity or expiration date, you may edit your information by accessing your "Account" page. It is your responsibility to keep your contact information and payment information current and updated.
+
+Cancelling Your Account
+
+Your Copy Upgraded Account will continue in effect unless and until you cancel your Upgraded Account or we terminate it. You must cancel your Upgraded Account before it renews each month or year in order to avoid billing of the next month's or year's fees to your credit card. Copy will bill the monthly or yearly fees associated with your Upgraded Account plus any applicable tax to the credit card you provide to us.
+
+You may cancel your Copy Upgraded Account at any time, and cancellation will be effective immediately. If you wish to cancel your Upgraded Account you may do so via your "Account" page. Should you elect to cancel your Upgraded Account, please note that you will not be issued a refund for the most recently (or any previously) charged monthly or annual fees.
+
+By signing up for a Copy Upgraded Account and providing Copy with your payment account information, you hereby agree to these payment terms and conditions.
+
+Free Accounts
+
+Copy allows you to store up to 2 GB free of charge. Copy reserves the right to change the amount of free storage or terminate Free Accounts at any time, with or without notice. Without limiting the generality of the foregoing, if a Free Account is inactive for ninety (90) days, then Copy may delete any or all of Your Files without providing additional notice.
+
+Term and Termination
+
+This Agreement is effective upon any use and remains in effect until your account is terminated. Terms which by their nature extend beyond termination shall survive termination of this Agreement.
+
+Your right to use Copy automatically terminates if you fail to comply with these Terms. Copy reserves the right to refuse or discontinue participation to any user at any time at its sole discretion. You agree that, upon such termination, you will discontinue all use of the Products and that your access rights will immediately terminate.
+
+If this Agreement terminates, other than for your failure to comply, Copy will use commercially reasonable efforts to make your Data available for you by request only for a period of fifteen (15) calendar days. Copy has no obligation to provide you with a copy of your Data and may remove and discard any Data.
+
+Disclaimer of Warranties
+
+THE PRODUCTS AND ANY THIRD PARTY SOFTWARE AND SERVICES ARE PROVIDED "AS IS," WITH NO WARRANTIES WHATSOEVER. COPY AND SUCH THIRD PARTIES EXPRESSLY DISCLAIM TO THE FULLEST EXTENT PERMITTED BY LAW ALL EXPRESS, IMPLIED, AND STATUTORY WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-INFRINGEMENT OF PROPRIETARY RIGHTS AND ANY WARRANTIES REGARDING THE SECURITY, RELIABILITY, TIMELINESS, AND PERFORMANCE OF THE PRODUCTS, SOFTWARE AND SERVICE AND SUCH THIRD PARTY SOFTWARE OR SERVICES.
+
+YOU UNDERSTAND AND AGREE THAT YOU USE THE PRODUCT, AND ALL THIRD PARTY SOFTWARE OR SERVICES MADE AVAILABLE IN CONJUNCTION WITH OR THROUGH THE PRODUCT, AT YOUR OWN DISCRETION AND RISK AND THAT YOU WILL BE SOLELY RESPONSIBLE FOR ANY DAMAGES TO YOUR COMPUTER SYSTEM OR LOSS OF DATA THAT RESULTS FROM THE USE OF THE PRODUCT AND SUCH THIRD PARTY SOFTWARE AND SERVICES.
+
+SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, AND WHERE THAT IS IN EFFECT, THE ABOVE EXCLUSIONS MAY NOT APPLY TO YOU.
+
+Limitation of Liability
+
+UNDER NO CIRCUMSTANCES SHALL COPY, OR ITS SUPPLIERS, RESELLERS, PARTNERS OR THEIR RESPECTIVE AFFILIATES BE LIABLE FOR ANY INDIRECT, INCIDENTAL, CONSEQUENTIAL, SPECIAL, EXEMPLARY, OR PUNITIVE DAMAGES ARISING FROM OR RELATED TO THE PRODUCT, WHETHER SUCH CLAIM IS BASED ON WARRANTY, CONTRACT, TORT (INCLUDING NEGLIGENCE), OR OTHERWISE, (EVEN IF COPY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES).
+
+WITHOUT LIMITING THE FOREGOING, THE TOTAL AGGREGATE LIABILITY OF COPY, AND ITS SUPPLIERS, RESELLERS, PARTNERS AND THEIR RESPECTIVE AFFILIATES ARISING FROM OR RELATED TO THIS AGREEMENT SHALL NOT EXCEED (i) US$25 IF NO AMOUNTS HAVE BEEN PAID BY YOU TO COPYOR (ii) THE AMOUTN PAID BY YOU FOR COPY IN THE THREE MONTH PERIOD IMMEDIATELY PRIOR TO THE CLAIM.
+
+THE FOREGOING LIMITATIONS OF LIABILITY SHALL APPLY WHETHER THE DAMAGES ARISE FROM USE OR MISUSE OF AND RELIANCE ON THE PRODUCT, FROM INABILITY TO USE THE PRODUCT, OR FROM THE INTERRUPTION, SUSPENSION, OR TERMINATION OF THE PRODUCT (INCLUDING SUCH DAMAGES INCURRED BY THIRD PARTIES). SUCH LIMITATION SHALL APPLY NOTWITHSTANDING A FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY AND TO THE FULLEST EXTENT PERMITTED BY LAW.
+
+SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR DEATH OR BODILY INJURY OR THE LIMITATIONS ABOVE AND IN THOSE JURISDICTIONS THE ABOVE LIMITATIONS AND EXCLUSIONS MAY NOT APPLY TO YOU.
+
+Export Restrictions
+
+You acknowledge and agree that the Product which is the subject of this Agreement, may be controlled for export purposes. You agree to comply with all United States export laws and regulations. You assume sole responsibility for any required export approval and/or licenses and all related costs and for the violation of any United States export law or regulation. If you are located in a country subject to embargo by the United States government, you are not entitled to use Copy.
+
+Governing Law, Dispute Resolution, and Venue
+
+THESE TERMS AND THE USE OF THE PRODUCT AND SOFTWARE WILL BE GOVERNED BY CALIFORNIA LAW EXCEPT FOR ITS CONFLICTS OF LAWS PRINCIPLES. ALL CLAIMS ARISING OUT OF OR RELATING TO THESE TERMS OR THE PRODUCT OR SOFTWARE MUST BE LITIGATED EXCLUSIVELY IN THE FEDERAL OR STATE COURTS OF SAN CLARA COUNTY, CALIFORNIA, AND BOTH PARTIES CONSENT TO VENUE AND PERSONAL JURISDICTION THERE.
+
+If a provision is found unenforceable the remaining provisions of the Agreement will remain in full effect and an enforceable term will be substituted which as closely as possible reflects Barracuda Networks intent.
+
+Entire Agreement and Assignment
+
+This Agreement, which incorporates the Barracuda Networks Copy Privacy Policy, constitutes the entire agreement between the parties with respect to the subject matter hereof and supersedes and replaces all prior or contemporaneous understandings or agreements, written or oral, regarding the Products. Barracuda Networks’ failure to enforce a provision is not a waiver of its right to do so later Any waiver of any provision of this Agreement will be effective only if in writing and signed by Barracuda Networks
+
+You may not assign or transfer any of your rights or obligations under this Agreement. Barracuda Networks may freely assign its rights and obligations and this Agreement. Any attempted assignment or transfer in violation of the foregoing will be void.
diff --git a/copy-agent.desktop b/copy-agent.desktop
new file mode 100644
index 000000000000..bfe4fbe19daa
--- /dev/null
+++ b/copy-agent.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Copy
+GenericName=Network Storage
+Comment=Copy.com Sync Agent
+Exec=CopyAgent
+Icon=copy-agent
+Terminal=false
+Type=Application
+Categories=Network;
+StartupNotify=false
diff --git a/copy-agent.install b/copy-agent.install
new file mode 100644
index 000000000000..660593cf5668
--- /dev/null
+++ b/copy-agent.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/copy-agent.png b/copy-agent.png
new file mode 100644
index 000000000000..a3116e23da98
--- /dev/null
+++ b/copy-agent.png
Binary files differ
diff --git a/copy-agent.service b/copy-agent.service
new file mode 100644
index 000000000000..43f0e11bbf31
--- /dev/null
+++ b/copy-agent.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=CopyAgent
+After=local-fs.target network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/CopyAgent
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/copy-console.service b/copy-console.service
new file mode 100644
index 000000000000..8a0198489370
--- /dev/null
+++ b/copy-console.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=CopyConsole
+After=local-fs.target network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/CopyConsole
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/launch.sh b/launch.sh
new file mode 100755
index 000000000000..7afe329b4b18
--- /dev/null
+++ b/launch.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+export LD_LIBRARY_PATH=/opt/copy
+exec /opt/copy/${0##*/} $@