summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-23 23:00:34 +0300
committerDimitris Kiziridis2020-04-23 23:00:34 +0300
commitbc0af0367a5ee5ef3c5caa6a42610341f441b80a (patch)
tree35fe747a9c80604dbe7e0756163c4148975b4a18
downloadaur-bc0af0367a5ee5ef3c5caa6a42610341f441b80a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9303ed439787
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = copy-pasta-git
+ pkgdesc = Universal copy paste service, works across different machines
+ pkgver = 0.0.1.r28.g954489a
+ pkgrel = 1
+ url = https://github.com/jutkko/copy-pasta
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = dep
+ makedepends = go-pie
+ provides = copy-pasta
+ source = git+https://github.com/jutkko/copy-pasta
+ md5sums = SKIP
+
+pkgname = copy-pasta-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92c6e4ff2d55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=copy-pasta-git
+pkgver=0.0.1.r28.g954489a
+pkgrel=1
+pkgdesc="Universal copy paste service, works across different machines"
+arch=('x86_64')
+url='https://github.com/jutkko/copy-pasta'
+license=('MIT')
+provides=("${pkgname%-git}")
+makedepends=('git' 'dep' 'go-pie')
+source=("git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p gopath/src/github.com/${pkgname%-git}
+ ln -rTsf ${pkgname%-git} gopath/src/github.com/${pkgname%-git}/${pkgname%-git}
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/${pkgname%-git}/${pkgname%-git}
+ dep init -v
+ dep ensure -v
+}
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/${pkgname%-git}/${pkgname%-git}
+ go install -v .
+}
+
+package() {
+ install -Dm755 "${srcdir}/gopath/bin/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+} \ No newline at end of file