summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-06-10 21:45:14 +0200
committerKenjiTakahashi2015-06-10 21:45:14 +0200
commit2f8f513aa8de56934881da3a99078a5ca7e78fe0 (patch)
treec80b02e0dc3ebcbed029b893dda5e267b837fac5
downloadaur-2f8f513aa8de56934881da3a99078a5ca7e78fe0.tar.gz
2.4.7-1: Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--copyq.install12
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abd09408f7d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = copyq
+ pkgdesc = Clipboard manager with searchable and editable history.
+ pkgver = 2.4.7
+ pkgrel = 1
+ url = https://github.com/hluk/CopyQ
+ install = copyq.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = qt4
+ depends = libxtst
+ optdepends = copyq-plugin-itemweb
+ source = https://github.com/hluk/CopyQ/archive/v2.4.7.tar.gz
+ md5sums = 4215c5e3fc0c5bb050b79f07cfb88a20
+
+pkgname = copyq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06d84f5331b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+
+pkgname=copyq
+_realname=CopyQ
+pkgver=2.4.7
+pkgrel=1
+pkgdesc="Clipboard manager with searchable and editable history."
+url="https://github.com/hluk/CopyQ"
+depends=('qt4' 'libxtst')
+optdepends=('copyq-plugin-itemweb')
+makedepends=('cmake')
+license=('GPL3')
+arch=('i686' 'x86_64')
+source=("https://github.com/hluk/${_realname}/archive/v${pkgver}.tar.gz")
+md5sums=('4215c5e3fc0c5bb050b79f07cfb88a20')
+install=copyq.install
+
+build() {
+ mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+ cmake -DWITH_WEBKIT=0 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ "${srcdir}/${_realname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/copyq.install b/copyq.install
new file mode 100644
index 000000000000..d43ea7c35e25
--- /dev/null
+++ b/copyq.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}