summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-11-30 04:52:54 +0100
committerKenjiTakahashi2015-11-30 05:06:53 +0100
commit5198aa2269cb478dd2cf315ca7beb17f7a5a8e16 (patch)
tree340f7bfaae881a6098b466a97ea4243ee1456555
parenteb11e6740794b613b5f9bb28a0113dec39e43911 (diff)
downloadaur-5198aa2269cb478dd2cf315ca7beb17f7a5a8e16.tar.gz
2.5.0-1: Bumped version, moved to Qt5, updated gitignore
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 852efece3b71..cf791f229f2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = copyq
pkgdesc = Clipboard manager with searchable and editable history.
- pkgver = 2.4.9
+ pkgver = 2.5.0
pkgrel = 1
url = https://github.com/hluk/CopyQ
install = copyq.install
@@ -8,11 +8,15 @@ pkgbase = copyq
arch = x86_64
license = GPL3
makedepends = cmake
- depends = qt4
+ makedepends = qt5-tools
+ makedepends = qt5-svg
depends = libxtst
+ depends = qt5-script
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
optdepends = copyq-plugin-itemweb
- source = https://github.com/hluk/CopyQ/archive/v2.4.9.tar.gz
- md5sums = 1e5dd7422c7f31ca85008c3c2bfd7a0d
+ source = https://github.com/hluk/CopyQ/archive/v2.5.0.tar.gz
+ md5sums = 7ecf002f6756cc8a360ca800fc670153
pkgname = copyq
diff --git a/.gitignore b/.gitignore
index 335ec9573de5..6fa1f3943279 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
*.tar.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 32d4f53ec455..dbbea9de1105 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
pkgname=copyq
_realname=CopyQ
-pkgver=2.4.9
+pkgver=2.5.0
pkgrel=1
pkgdesc="Clipboard manager with searchable and editable history."
url="https://github.com/hluk/CopyQ"
-depends=('qt4' 'libxtst')
+depends=('libxtst' 'qt5-script' 'hicolor-icon-theme' 'desktop-file-utils')
optdepends=('copyq-plugin-itemweb')
-makedepends=('cmake')
+makedepends=('cmake' 'qt5-tools' 'qt5-svg')
license=('GPL3')
arch=('i686' 'x86_64')
source=("https://github.com/hluk/${_realname}/archive/v${pkgver}.tar.gz")
-md5sums=('1e5dd7422c7f31ca85008c3c2bfd7a0d')
+md5sums=('7ecf002f6756cc8a360ca800fc670153')
install=copyq.install
build() {
mkdir "${srcdir}/build"
cd "${srcdir}/build"
- cmake -DWITH_WEBKIT=0 \
+ cmake \
+ -DWITH_WEBKIT=0 \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ -DWITH_QT5=TRUE \
"${srcdir}/${_realname}-${pkgver}"
make
}