summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2023-10-22 11:57:58 +0200
committeraksr2023-10-22 11:57:58 +0200
commit41d4fa08d89dcaeee776e15c9574115f1dd06c03 (patch)
tree798e19ba5941c83d5664baf6428f250de14c91eb
parent6d45e14a945f7b7444a2e83d7faa616466ca4675 (diff)
downloadaur-copyq-git.tar.gz
Update depends().
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7adf66553e89..6fdebeefe1c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Apr 24 08:48:21 UTC 2021
pkgbase = copyq-git
pkgdesc = Clipboard manager with searchable and editable history.
- pkgver = r5499.9c53b6ac
+ pkgver = r6078.19e9dd1c
pkgrel = 1
epoch = 1
url = https://github.com/hluk/CopyQ
@@ -19,7 +17,7 @@ pkgbase = copyq-git
depends = qt5-svg
depends = qt5-x11extras
depends = desktop-file-utils
- depends = knotifications
+ depends = knotifications5
optdepends = copyq-plugin-itemweb-git
provides = copyq
conflicts = copyq
@@ -27,4 +25,3 @@ pkgbase = copyq-git
md5sums = SKIP
pkgname = copyq-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6a45de883460..3595387342c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Karol "Kenji Takahashi" Woźniak <kenji.sx>
# Maintainer: aksr <aksr at t-com dot me>
pkgname=copyq-git
-pkgver=r5499.9c53b6ac
+pkgver=r6078.19e9dd1c
pkgrel=1
epoch=1
pkgdesc="Clipboard manager with searchable and editable history."
url="https://github.com/hluk/CopyQ"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('hicolor-icon-theme' 'libxtst' 'qt5-script' 'qt5-svg' 'qt5-x11extras' 'desktop-file-utils' 'knotifications')
+depends=('hicolor-icon-theme' 'libxtst' 'qt5-script' 'qt5-svg' 'qt5-x11extras' 'desktop-file-utils' 'knotifications5')
makedepends=('git' 'cmake' 'extra-cmake-modules' 'qt5-tools')
optdepends=('copyq-plugin-itemweb-git')
provides=('copyq')
@@ -19,22 +19,21 @@ md5sums=('SKIP')
install=
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/$pkgname"
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DWITH_WEBKIT=0 \
- -DWITH_QT5=TRUE $srcdir/$pkgname
- make
+ cd "$srcdir/$pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_WEBKIT=0 \
+ -DWITH_QT5=TRUE $srcdir/$pkgname
+ make
}
package() {
- cd "$srcdir/$pkgname/build"
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/$pkgname/build"
+ make DESTDIR="$pkgdir" install
}
-