summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-06-10 21:46:08 +0200
committerKenjiTakahashi2015-06-10 21:46:08 +0200
commit469f99c04e74eb02d73118e644bb5ef9ee34d3bf (patch)
tree067bb17d354a7c95ff549e243b989b52c7d6b9b0
downloadaur-469f99c04e74eb02d73118e644bb5ef9ee34d3bf.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--copyq.install12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1c0acd99f34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = copyq-git
+ pkgdesc = Clipboard manager with searchable and editable history.
+ pkgver = 20140202
+ pkgrel = 1
+ url = https://github.com/hluk/CopyQ
+ install = copyq.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = qt4
+ depends = libxtst
+ optdepends = copyq-plugin-itemweb-git
+ provides = copyq
+ conflicts = copyq
+ source = copyq-git::git+https://github.com/hluk/CopyQ.git
+ md5sums = SKIP
+
+pkgname = copyq-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fe24e9dfc63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+# Contributor: SanskritFritz (gmail)
+
+pkgname=copyq-git
+pkgver=20140202
+pkgrel=1
+pkgdesc="Clipboard manager with searchable and editable history."
+url="https://github.com/hluk/CopyQ"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qt4' 'libxtst')
+optdepends=('copyq-plugin-itemweb-git')
+makedepends=('cmake' 'git')
+provides=('copyq')
+conflicts=('copyq')
+source=("${pkgname}::git+https://github.com/hluk/CopyQ.git")
+md5sums=('SKIP')
+install=copyq.install
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+build() {
+ mkdir -p ${srcdir}/${pkgname}/build
+ cd ${srcdir}/${pkgname}/build
+ cmake -DWITH_WEBKIT=0 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ ${srcdir}/${pkgname}
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}/build
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/copyq.install b/copyq.install
new file mode 100644
index 000000000000..d43ea7c35e25
--- /dev/null
+++ b/copyq.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}