summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-11-30 05:13:54 +0100
committerKenjiTakahashi2015-11-30 05:13:54 +0100
commitb4f02d63c407bd59488cc42cc2ad8fe457d85f66 (patch)
treecbed06d28c070e3160c8fa5f26032d4779075596
parent469f99c04e74eb02d73118e644bb5ef9ee34d3bf (diff)
downloadaur-b4f02d63c407bd59488cc42cc2ad8fe457d85f66.tar.gz
git: Moved to Qt5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1c0acd99f34..a755834e804a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = copyq-git
pkgdesc = Clipboard manager with searchable and editable history.
- pkgver = 20140202
+ pkgver = 20151130
pkgrel = 1
url = https://github.com/hluk/CopyQ
install = copyq.install
@@ -9,8 +9,12 @@ pkgbase = copyq-git
license = GPL3
makedepends = cmake
makedepends = git
- depends = qt4
+ makedepends = qt5-tools
+ makedepends = qt5-svg
depends = libxtst
+ depends = qt5-script
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
optdepends = copyq-plugin-itemweb-git
provides = copyq
conflicts = copyq
diff --git a/PKGBUILD b/PKGBUILD
index 1fe24e9dfc63..db046f674eda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: SanskritFritz (gmail)
pkgname=copyq-git
-pkgver=20140202
+pkgver=20151130
pkgrel=1
pkgdesc="Clipboard manager with searchable and editable history."
url="https://github.com/hluk/CopyQ"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('qt4' 'libxtst')
+depends=('libxtst' 'qt5-script' 'hicolor-icon-theme' 'desktop-file-utils')
optdepends=('copyq-plugin-itemweb-git')
-makedepends=('cmake' 'git')
+makedepends=('cmake' 'git' 'qt5-tools' 'qt5-svg')
provides=('copyq')
conflicts=('copyq')
source=("${pkgname}::git+https://github.com/hluk/CopyQ.git")
@@ -25,9 +25,10 @@ pkgver() {
build() {
mkdir -p ${srcdir}/${pkgname}/build
cd ${srcdir}/${pkgname}/build
- cmake -DWITH_WEBKIT=0 \
+ cmake \
+ -DWITH_WEBKIT=0 \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ -DWITH_QT5=TRUE \
${srcdir}/${pkgname}
make
}