summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-11-30 05:13:20 +0100
committerKenjiTakahashi2015-11-30 05:13:20 +0100
commita50547f8826dd8ad378ac72a93283a5d1f3504ad (patch)
tree38734e2c4fa14e307dfbd6fa4bcb6f7e1005aa0a
parent82cac9234da6cf2a0f67599605ace6dc6bdacb43 (diff)
downloadaur-a50547f8826dd8ad378ac72a93283a5d1f3504ad.tar.gz
2.5.0-1: Bumped version, moved to Qt5, added gitignore
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD13
3 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fae5d84e265..e9d46853e0f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = copyq-plugin-itemweb
pkgdesc = Clipboard manager with searchable and editable history. Itemweb plugin.
- pkgver = 2.4.9
+ pkgver = 2.5.0
pkgrel = 1
url = https://github.com/hluk/CopyQ
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
- depends = qtwebkit
+ makedepends = qt5-tools
+ makedepends = qt5-svg
depends = copyq
- source = https://github.com/hluk/CopyQ/archive/v2.4.9.tar.gz
- md5sums = 1e5dd7422c7f31ca85008c3c2bfd7a0d
+ depends = qt5-webkit
+ source = https://github.com/hluk/CopyQ/archive/v2.5.0.tar.gz
+ md5sums = 7ecf002f6756cc8a360ca800fc670153
pkgname = copyq-plugin-itemweb
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8888f35b6dc5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.xz
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
index e0e5f872456c..cff2ba337f48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,23 @@
pkgname=copyq-plugin-itemweb
_realname=CopyQ
-pkgver=2.4.9
+pkgver=2.5.0
pkgrel=1
pkgdesc="Clipboard manager with searchable and editable history. Itemweb plugin."
url="https://github.com/hluk/CopyQ"
-depends=('qtwebkit' 'copyq')
-makedepends=('cmake')
+depends=('copyq' 'qt5-webkit')
+makedepends=('cmake' 'qt5-tools' 'qt5-svg')
license=('GPL3')
arch=('i686' 'x86_64')
source=("https://github.com/hluk/$_realname/archive/v${pkgver}.tar.gz")
-md5sums=('1e5dd7422c7f31ca85008c3c2bfd7a0d')
+md5sums=('7ecf002f6756cc8a360ca800fc670153')
build() {
mkdir "${srcdir}/build"
cd "${srcdir}/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QT5=TRUE \
"${srcdir}/${_realname}-${pkgver}"
make itemweb
}