summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-06-10 21:49:02 +0200
committerKenjiTakahashi2015-06-10 21:49:02 +0200
commitb3d4eefe7af5915edbd02efba0742c5f77d75d4e (patch)
tree223195201d292294165ef6b2b233eedbfe98698c
downloadaur-b3d4eefe7af5915edbd02efba0742c5f77d75d4e.tar.gz
2.4.7-1: Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db199f931051
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = copyq-plugin-itemweb
+ pkgdesc = Clipboard manager with searchable and editable history. Itemweb plugin.
+ pkgver = 2.4.7
+ pkgrel = 1
+ url = https://github.com/hluk/CopyQ
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = qtwebkit
+ depends = copyq
+ source = https://github.com/hluk/CopyQ/archive/v2.4.7.tar.gz
+ md5sums = 4215c5e3fc0c5bb050b79f07cfb88a20
+
+pkgname = copyq-plugin-itemweb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9069b332b36b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+
+pkgname=copyq-plugin-itemweb
+_realname=CopyQ
+pkgver=2.4.7
+pkgrel=1
+pkgdesc="Clipboard manager with searchable and editable history. Itemweb plugin."
+url="https://github.com/hluk/CopyQ"
+depends=('qtwebkit' 'copyq')
+makedepends=('cmake')
+license=('GPL3')
+arch=('i686' 'x86_64')
+source=("https://github.com/hluk/$_realname/archive/v${pkgver}.tar.gz")
+md5sums=('4215c5e3fc0c5bb050b79f07cfb88a20')
+
+build() {
+ mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ "${srcdir}/${_realname}-${pkgver}"
+ make itemweb
+}
+
+package() {
+ cd "${srcdir}/build"
+ install -Dm755 plugins/libitemweb.so "${pkgdir}/usr/lib/copyq/plugins/libitemweb.so"
+}
+
+# vim:set ts=4 sw=4 et: