summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-11-30 05:14:14 +0100
committerKenjiTakahashi2015-11-30 05:14:14 +0100
commit58d5fbae7c61390365587353dd59236c81be1c3b (patch)
tree6bb1f780b6b597b2c1e083f77266fbe6abd68f73
parent8ccfcad1478765cc3aa35afdad35223e04c1ac34 (diff)
downloadaur-58d5fbae7c61390365587353dd59236c81be1c3b.tar.gz
git: Moved to Qt5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcd8c5b04301..405ea8a31eb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = copyq-plugin-itemweb-git
pkgdesc = Clipboard manager with searchable and editable history. Itemweb plugin.
- pkgver = 20140126
+ pkgver = 20151130
pkgrel = 1
url = https://github.com/hluk/CopyQ
arch = i686
@@ -8,7 +8,9 @@ pkgbase = copyq-plugin-itemweb-git
license = GPL3
makedepends = cmake
makedepends = git
- depends = qtwebkit
+ makedepends = qt5-tools
+ makedepends = qt5-svg
+ depends = qt5-webkit
depends = copyq-git
provides = copyq-plugin-itemweb
conflicts = copyq-plugin-itemweb
diff --git a/PKGBUILD b/PKGBUILD
index 36c8aec2fbdf..3d762ebadae8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
pkgname=copyq-plugin-itemweb-git
-pkgver=20140126
+pkgver=20151130
pkgrel=1
pkgdesc="Clipboard manager with searchable and editable history. Itemweb plugin."
url="https://github.com/hluk/CopyQ"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('qtwebkit' 'copyq-git')
-makedepends=('cmake' 'git')
+depends=('qt5-webkit' 'copyq-git')
+makedepends=('cmake' 'git' 'qt5-tools' 'qt5-svg')
provides=('copyq-plugin-itemweb')
conflicts=('copyq-plugin-itemweb')
source=("${pkgname}::git+https://github.com/hluk/CopyQ.git")
@@ -22,8 +22,9 @@ pkgver() {
build() {
mkdir -p ${srcdir}/${pkgname}/build
cd ${srcdir}/${pkgname}/build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QT5=TRUE \
${srcdir}/${pkgname}
make itemweb
}