summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-06-10 21:49:41 +0200
committerKenjiTakahashi2015-06-10 21:49:41 +0200
commit8ccfcad1478765cc3aa35afdad35223e04c1ac34 (patch)
tree3679f5e44d668bde556d34050d496482bce3df7a
downloadaur-8ccfcad1478765cc3aa35afdad35223e04c1ac34.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcd8c5b04301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = copyq-plugin-itemweb-git
+ pkgdesc = Clipboard manager with searchable and editable history. Itemweb plugin.
+ pkgver = 20140126
+ pkgrel = 1
+ url = https://github.com/hluk/CopyQ
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = qtwebkit
+ depends = copyq-git
+ provides = copyq-plugin-itemweb
+ conflicts = copyq-plugin-itemweb
+ source = copyq-plugin-itemweb-git::git+https://github.com/hluk/CopyQ.git
+ md5sums = SKIP
+
+pkgname = copyq-plugin-itemweb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36c8aec2fbdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+
+pkgname=copyq-plugin-itemweb-git
+pkgver=20140126
+pkgrel=1
+pkgdesc="Clipboard manager with searchable and editable history. Itemweb plugin."
+url="https://github.com/hluk/CopyQ"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qtwebkit' 'copyq-git')
+makedepends=('cmake' 'git')
+provides=('copyq-plugin-itemweb')
+conflicts=('copyq-plugin-itemweb')
+source=("${pkgname}::git+https://github.com/hluk/CopyQ.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+build() {
+ mkdir -p ${srcdir}/${pkgname}/build
+ cd ${srcdir}/${pkgname}/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ ${srcdir}/${pkgname}
+ make itemweb
+}
+
+package() {
+ cd ${srcdir}/${pkgname}/build
+ install -Dm755 plugins/libitemweb.so $pkgdir/usr/lib/copyq/plugins/libitemweb.so
+ rm -rf ${srdir}/${pkgname}/build
+}
+
+# vim:set ts=4 sw=4 et: