summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-08-08 02:42:01 +0200
committerM0Rf302015-08-08 02:42:01 +0200
commite69424a562700ef7986d8a78270b2dac248e2a0d (patch)
tree53c1e8153b2317bb0ac096fb82eb005d45c119ec
downloadaur-e69424a562700ef7986d8a78270b2dac248e2a0d.tar.gz
3.9.4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--patch.diff13
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38ddc4cb376a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = coral
+ pkgdesc = A set of drivers, libraries, utilities and analysis software for ATM and PoS OCx monitors and pcap interfaces
+ pkgver = 3.9.4
+ pkgrel = 1
+ url = https://www.caida.org/tools/measurement/coralreef/status.xml
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = perl
+ source = https://www.caida.org/tools/measurement/coralreef/dists/coral-3.9.4.tar.gz
+ source = patch.diff
+ md5sums = c2e392d097e7afa7c087c0a2b5af0dd8
+ md5sums = 199ab35e8d42242c263c827387ea11d8
+
+pkgname = coral
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..267914c6997d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: M0Rf30
+
+pkgname=coral
+pkgver=3.9.4
+pkgrel=1
+pkgdesc="A set of drivers, libraries, utilities and analysis software for ATM and PoS OCx monitors and pcap interfaces"
+url="https://www.caida.org/tools/measurement/coralreef/status.xml"
+arch=('i686' 'x86_64')
+depends=('perl')
+source=("https://www.caida.org/tools/measurement/coralreef/dists/$pkgname-$pkgver.tar.gz"
+ patch.diff)
+
+license=('MIT')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -Np1 -i ../patch.diff
+ find . -type f -exec sed -i -e 's/-DHAS_BOOL/-D__USE_BSD -D_GNU_SOURCE/g' {} +
+ ./configure --prefix=/usr
+ make
+ make DESTDIR=$pkgdir install
+}
+
+md5sums=('c2e392d097e7afa7c087c0a2b5af0dd8'
+ '199ab35e8d42242c263c827387ea11d8')
diff --git a/patch.diff b/patch.diff
new file mode 100644
index 000000000000..836023417a4a
--- /dev/null
+++ b/patch.diff
@@ -0,0 +1,13 @@
+--- a/libsrc/CRL/Unpack.c 2014-10-15 23:04:20.000000000 +0200
++++ b/libsrc/CRL/Unpack.c 2015-08-06 17:41:49.008954127 +0200
+@@ -1447,9 +1447,6 @@
+ #ifdef eof
+ #undef eof
+ #endif
+-#ifdef bool
+- #undef bool
+-#endif
+ #ifdef close
+ #undef close
+ #endif
+