summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Wambold2019-11-13 15:11:12 -0500
committerTom Wambold2019-11-13 15:11:12 -0500
commit10efe0a5b9841117921c3873bec8571138fe3e05 (patch)
tree4f3fe9d697d0007baf3c2dc0927d06055f857cbe
parent2973ed58fc78d2f6ecfaaf347a009b1be79b40d6 (diff)
downloadaur-10efe0a5b9841117921c3873bec8571138fe3e05.tar.gz
Update to CORE 5.5.2 release.
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD42
-rw-r--r--python-lib-dir.patch24
-rw-r--r--sphinx-apidoc2.patch24
-rw-r--r--systemd-service-dir.patch12
5 files changed, 81 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f43893387071..1ef102c241f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = core
pkgdesc = Common Open Research Emulator
- pkgver = 5.1
+ pkgver = 5.5.2
pkgrel = 1
url = https://github.com/coreemu/core/
arch = i686
@@ -8,23 +8,31 @@ pkgbase = core
license = BSD
makedepends = help2man
makedepends = imagemagick
- makedepends = python2-sphinx
+ makedepends = python-sphinx
+ makedepends = python-grpcio-tools
makedepends = openvswitch
- depends = libev
+ depends = bridge-utils
depends = ebtables
+ depends = ethtool
depends = iproute2
- depends = python2
- depends = python2-enum34
- depends = bridge-utils
+ depends = libev
+ depends = openvswitch
+ depends = procps-ng
+ depends = python3
+ depends = python-future
+ depends = python-grpcio
+ depends = python-lxml
depends = tkimg
+ depends = util-linux
depends = xterm
- conflicts = core-svn
+ optdepends = openvswitch: Open vSwitch support
backup = etc/core/core.conf
- backup = etc/core/perflogserver.conf
- source = https://github.com/coreemu/core/archive/release-5.1.tar.gz
- source = sphinx-apidoc2.patch
- md5sums = ff100baf762170d1e8f124b9493b98f5
- md5sums = a636bfcf4865709855079f3053504dda
+ source = https://github.com/coreemu/core/archive/release-5.5.2.tar.gz
+ source = python-lib-dir.patch
+ source = systemd-service-dir.patch
+ md5sums = 15414de3e9a43664c86894aca039a6a7
+ md5sums = e3ce4e27688f93a07a0388c93aab2a5a
+ md5sums = 43189fc4c5eff0bfbf0464c407a15bec
pkgname = core
diff --git a/PKGBUILD b/PKGBUILD
index 082921ed375a..f959ecfd9f7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,47 @@
# Maintainer: Tom Wambold <tom5760@gmail.com>
pkgname=core
-pkgver=5.1
+pkgver=5.5.2
pkgrel=1
pkgdesc="Common Open Research Emulator"
arch=('i686' 'x86_64')
url="https://github.com/coreemu/core/"
license=('BSD')
-depends=('libev' 'ebtables' 'iproute2' 'python2' 'python2-enum34'
- 'bridge-utils' 'tkimg' 'xterm')
-makedepends=('help2man' 'imagemagick' 'python2-sphinx' 'openvswitch')
-conflicts=('core-svn')
-backup=('etc/core/core.conf' 'etc/core/perflogserver.conf')
+depends=('bridge-utils' 'ebtables' 'ethtool' 'iproute2' 'libev' 'openvswitch'
+ 'procps-ng' 'python3' 'python-future' 'python-grpcio' 'python-lxml' 'tkimg'
+ 'util-linux' 'xterm')
+makedepends=('help2man' 'imagemagick' 'python-sphinx' 'python-grpcio-tools'
+ 'openvswitch')
+optdepends=('openvswitch: Open vSwitch support')
+backup=('etc/core/core.conf')
source=("https://github.com/coreemu/core/archive/release-$pkgver.tar.gz"
- 'sphinx-apidoc2.patch')
-md5sums=('ff100baf762170d1e8f124b9493b98f5'
- 'a636bfcf4865709855079f3053504dda')
+ 'python-lib-dir.patch'
+ 'systemd-service-dir.patch')
+md5sums=('15414de3e9a43664c86894aca039a6a7'
+ 'e3ce4e27688f93a07a0388c93aab2a5a'
+ '43189fc4c5eff0bfbf0464c407a15bec')
-build() {
+prepare() {
cd "$srcdir/core-release-$pkgver"
- patch -p1 < ../sphinx-apidoc2.patch
+ patch -p1 < "$srcdir/python-lib-dir.patch"
+ patch -p1 < "$srcdir/systemd-service-dir.patch"
+}
+
+build() {
+ cd "$srcdir/core-release-$pkgver"
./bootstrap.sh
- ./configure CFLAGS=-fno-strict-aliasing PYTHON=/usr/bin/python2 --prefix=/usr
+ ./configure \
+ --prefix=/usr \
+ --with-startup=systemd \
+ --enable-python3 \
+ --enable-docs
make
}
package() {
cd "$srcdir/core-release-$pkgver"
make DESTDIR="$pkgdir/" install
-
- rm "$pkgdir/etc/init.d/core-daemon"
- rmdir "$pkgdir/etc/init.d"
-
- install -D "$srcdir/core-release-$pkgver/scripts/core-daemon.service" "$pkgdir/usr/lib/systemd/system/core-daemon.service"
}
# vim:set ts=2 sw=2 et:
diff --git a/python-lib-dir.patch b/python-lib-dir.patch
new file mode 100644
index 000000000000..bafa83ef6261
--- /dev/null
+++ b/python-lib-dir.patch
@@ -0,0 +1,24 @@
+diff -Naur a/daemon/Makefile.am b/daemon/Makefile.am
+--- a/daemon/Makefile.am 2019-10-12 17:26:38.000000000 -0400
++++ b/daemon/Makefile.am 2019-11-13 14:56:10.154495566 -0500
+@@ -14,7 +14,7 @@
+ DOCS = doc
+ endif
+
+-PYTHONLIBDIR=$(subst site-packages,dist-packages,$(pythondir))
++PYTHONLIBDIR=$(pythondir)
+
+ SUBDIRS = proto $(DOCS)
+
+diff -Naur a/ns3/Makefile.am b/ns3/Makefile.am
+--- a/ns3/Makefile.am 2019-10-12 17:26:38.000000000 -0400
++++ b/ns3/Makefile.am 2019-11-13 14:56:18.600662969 -0500
+@@ -9,7 +9,7 @@
+
+ if WANT_PYTHON
+
+-PYTHONLIBDIR=$(subst site-packages,dist-packages,$(pythondir))
++PYTHONLIBDIR=$(pythondir)
+
+ SETUPPY = setup.py
+ SETUPPYFLAGS = -v
diff --git a/sphinx-apidoc2.patch b/sphinx-apidoc2.patch
deleted file mode 100644
index cbb2c6415904..000000000000
--- a/sphinx-apidoc2.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur b/configure.ac a/configure.ac
---- b/configure.ac 2018-05-31 00:20:52.000000000 -0400
-+++ a/configure.ac 2018-06-06 13:47:43.242993733 -0400
-@@ -163,7 +163,7 @@
- fi
-
- # check for sphinx required during make
--AC_CHECK_PROG(sphinxapi_path, sphinx-apidoc, $as_dir, no, $SEARCHPATH)
-+AC_CHECK_PROG(sphinxapi_path, sphinx-apidoc2, $as_dir, no, $SEARCHPATH)
- if test "x$sphinxapi_path" = "xno" ; then
- AC_MSG_ERROR(["Could not location sphinx-apidoc, from the python-sphinx package"])
- fi
-diff -Naur b/daemon/doc/Makefile.am a/daemon/doc/Makefile.am
---- b/daemon/doc/Makefile.am 2018-05-31 00:20:52.000000000 -0400
-+++ a/daemon/doc/Makefile.am 2018-06-06 13:47:56.053038681 -0400
-@@ -14,7 +14,7 @@
-
- # auto-generated Python documentation using Sphinx
- index.rst:
-- sphinx-apidoc -o . ../core
-+ sphinx-apidoc2 -o . ../core
- mv modules.rst index.rst
-
- ###### below this line was generated using sphinx-quickstart ######
diff --git a/systemd-service-dir.patch b/systemd-service-dir.patch
new file mode 100644
index 000000000000..276c561e3cfd
--- /dev/null
+++ b/systemd-service-dir.patch
@@ -0,0 +1,12 @@
+diff -Naur a/scripts/Makefile.am b/scripts/Makefile.am
+--- a/scripts/Makefile.am 2019-10-12 17:26:38.000000000 -0400
++++ b/scripts/Makefile.am 2019-11-13 14:57:54.735399061 -0500
+@@ -22,7 +22,7 @@
+ startup_SCRIPTS = core-daemon
+ endif
+ if WANT_SYSTEMD
+-startupdir = /etc/systemd/system
++startupdir = /usr/lib/systemd/system
+ startup_SCRIPTS = core-daemon.service
+ endif
+