summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Wambold2020-01-10 13:46:11 -0500
committerTom Wambold2020-01-10 13:47:49 -0500
commit3b2c54d68638a01d8e0f112181304ab8a4fa6f24 (patch)
tree26ad1ad52b6ad2873192d4b21fb3c5a60b952021
parent10efe0a5b9841117921c3873bec8571138fe3e05 (diff)
downloadaur-3b2c54d68638a01d8e0f112181304ab8a4fa6f24.tar.gz
Update to CORE 6.0.0 release.
* Removed unused python install dir patch. * Added additional dependencies for new Python/TK GUI.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--python-lib-dir.patch24
3 files changed, 11 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ef102c241f0..49ed215ab5d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = core
pkgdesc = Common Open Research Emulator
- pkgver = 5.5.2
+ pkgver = 6.0.0
pkgrel = 1
url = https://github.com/coreemu/core/
arch = i686
@@ -14,6 +14,7 @@ pkgbase = core
depends = bridge-utils
depends = ebtables
depends = ethtool
+ depends = fabric
depends = iproute2
depends = libev
depends = openvswitch
@@ -22,16 +23,16 @@ pkgbase = core
depends = python-future
depends = python-grpcio
depends = python-lxml
+ depends = python-netaddr
+ depends = python-pillow
depends = tkimg
depends = util-linux
depends = xterm
optdepends = openvswitch: Open vSwitch support
backup = etc/core/core.conf
- source = https://github.com/coreemu/core/archive/release-5.5.2.tar.gz
- source = python-lib-dir.patch
+ source = https://github.com/coreemu/core/archive/release-6.0.0.tar.gz
source = systemd-service-dir.patch
- md5sums = 15414de3e9a43664c86894aca039a6a7
- md5sums = e3ce4e27688f93a07a0388c93aab2a5a
+ md5sums = f6840ba27297b0d0168fd158a2919fd2
md5sums = 43189fc4c5eff0bfbf0464c407a15bec
pkgname = core
diff --git a/PKGBUILD b/PKGBUILD
index f959ecfd9f7d..4dd6203dc435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
# Maintainer: Tom Wambold <tom5760@gmail.com>
pkgname=core
-pkgver=5.5.2
+pkgver=6.0.0
pkgrel=1
pkgdesc="Common Open Research Emulator"
arch=('i686' 'x86_64')
url="https://github.com/coreemu/core/"
license=('BSD')
-depends=('bridge-utils' 'ebtables' 'ethtool' 'iproute2' 'libev' 'openvswitch'
- 'procps-ng' 'python3' 'python-future' 'python-grpcio' 'python-lxml' 'tkimg'
- 'util-linux' 'xterm')
+depends=('bridge-utils' 'ebtables' 'ethtool' 'fabric' 'iproute2' 'libev'
+ 'openvswitch' 'procps-ng' 'python3' 'python-future' 'python-grpcio'
+ 'python-lxml' 'python-netaddr' 'python-pillow' 'tkimg' 'util-linux' 'xterm')
makedepends=('help2man' 'imagemagick' 'python-sphinx' 'python-grpcio-tools'
'openvswitch')
optdepends=('openvswitch: Open vSwitch support')
backup=('etc/core/core.conf')
source=("https://github.com/coreemu/core/archive/release-$pkgver.tar.gz"
- 'python-lib-dir.patch'
'systemd-service-dir.patch')
-md5sums=('15414de3e9a43664c86894aca039a6a7'
- 'e3ce4e27688f93a07a0388c93aab2a5a'
+md5sums=('f6840ba27297b0d0168fd158a2919fd2'
'43189fc4c5eff0bfbf0464c407a15bec')
prepare() {
cd "$srcdir/core-release-$pkgver"
- patch -p1 < "$srcdir/python-lib-dir.patch"
patch -p1 < "$srcdir/systemd-service-dir.patch"
}
@@ -34,7 +31,6 @@ build() {
./configure \
--prefix=/usr \
--with-startup=systemd \
- --enable-python3 \
--enable-docs
make
}
diff --git a/python-lib-dir.patch b/python-lib-dir.patch
deleted file mode 100644
index bafa83ef6261..000000000000
--- a/python-lib-dir.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur a/daemon/Makefile.am b/daemon/Makefile.am
---- a/daemon/Makefile.am 2019-10-12 17:26:38.000000000 -0400
-+++ b/daemon/Makefile.am 2019-11-13 14:56:10.154495566 -0500
-@@ -14,7 +14,7 @@
- DOCS = doc
- endif
-
--PYTHONLIBDIR=$(subst site-packages,dist-packages,$(pythondir))
-+PYTHONLIBDIR=$(pythondir)
-
- SUBDIRS = proto $(DOCS)
-
-diff -Naur a/ns3/Makefile.am b/ns3/Makefile.am
---- a/ns3/Makefile.am 2019-10-12 17:26:38.000000000 -0400
-+++ b/ns3/Makefile.am 2019-11-13 14:56:18.600662969 -0500
-@@ -9,7 +9,7 @@
-
- if WANT_PYTHON
-
--PYTHONLIBDIR=$(subst site-packages,dist-packages,$(pythondir))
-+PYTHONLIBDIR=$(pythondir)
-
- SETUPPY = setup.py
- SETUPPYFLAGS = -v