summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Wambold2015-06-25 11:56:58 -0400
committerTom Wambold2015-06-25 11:56:58 -0400
commit90dd29789a6443b931c03e3bb186d7e0a4fe0dcc (patch)
tree97e81958c182a54e0835a8e902bb38a8dd52ff12
downloadaur-90dd29789a6443b931c03e3bb186d7e0a4fe0dcc.tar.gz
Initial commit.
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD43
-rw-r--r--core-daemon.service11
-rw-r--r--python2.patch81
5 files changed, 168 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..514ffa038b83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = core
+ pkgdesc = Common Open Research Emulator
+ pkgver = 4.8
+ pkgrel = 1
+ url = http://cs.itd.nrl.navy.mil/work/core/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = dia
+ makedepends = help2man
+ makedepends = imagemagick
+ depends = libev
+ depends = ebtables
+ depends = iproute2
+ depends = python2
+ depends = bridge-utils
+ depends = tkimg
+ depends = xterm
+ conflicts = core-svn
+ backup = etc/core/core.conf
+ backup = etc/core/perflogserver.conf
+ source = http://downloads.pf.itd.nrl.navy.mil/core/source/core-4.8.tar.gz
+ source = core-daemon.service
+ source = python2.patch
+ md5sums = 20b3f10d0093af22c40423984e21aeee
+ md5sums = 256e39a074f36f7f1683e88324682c9e
+ md5sums = d80b160009135529e96986538b0d10a9
+
+pkgname = core
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9536cb6f1ff2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+/core-*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d917a5125554
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Tom Wambold <tom5760@gmail.com>
+pkgname=core
+pkgver=4.8
+pkgrel=1
+pkgdesc="Common Open Research Emulator"
+arch=('i686' 'x86_64')
+url="http://cs.itd.nrl.navy.mil/work/core/"
+license=('BSD')
+depends=('libev' 'ebtables' 'iproute2' 'python2' 'bridge-utils' 'tkimg'
+ 'xterm')
+makedepends=('dia' 'help2man' 'imagemagick')
+conflicts=('core-svn')
+backup=('etc/core/core.conf' 'etc/core/perflogserver.conf')
+source=("http://downloads.pf.itd.nrl.navy.mil/core/source/$pkgname-$pkgver.tar.gz"
+ 'core-daemon.service'
+ 'python2.patch')
+md5sums=('20b3f10d0093af22c40423984e21aeee'
+ '256e39a074f36f7f1683e88324682c9e'
+ 'd80b160009135529e96986538b0d10a9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p1 < ../python2.patch
+
+ ./configure CPPFLAGS=-Wno-strict-aliasing PYTHON=/usr/bin/python2 --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ rm "$pkgdir/etc/init.d/core-daemon"
+ rmdir "$pkgdir/etc/init.d"
+
+ install -D "$srcdir/core-daemon.service" "$pkgdir/usr/lib/systemd/system/core-daemon.service"
+
+ mv "$pkgdir/usr/sbin/"* "$pkgdir/usr/bin/"
+ rmdir "$pkgdir/usr/sbin"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/core-daemon.service b/core-daemon.service
new file mode 100644
index 000000000000..089571f495cd
--- /dev/null
+++ b/core-daemon.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Common Open Research Emulator Service
+After=network.target
+
+[Service]
+Type=simple
+PIDFile=/run/cored.pid
+ExecStart=/usr/bin/python2 /usr/sbin/core-daemon -i /run/cored.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..73e72b96c574
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,81 @@
+diff -Naur a/daemon/core/misc/LatLongUTMconversion.py b/daemon/core/misc/LatLongUTMconversion.py
+--- a/daemon/core/misc/LatLongUTMconversion.py 2015-06-05 10:19:41.000000000 -0400
++++ b/daemon/core/misc/LatLongUTMconversion.py 2015-06-25 11:53:31.249286410 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # this file is from http://pygps.org/
+
+ # Lat Long - UTM, UTM - Lat Long conversions
+diff -Naur a/daemon/examples/emanemodel2core.py b/daemon/examples/emanemodel2core.py
+--- a/daemon/examples/emanemodel2core.py 2015-06-05 10:19:41.000000000 -0400
++++ b/daemon/examples/emanemodel2core.py 2015-06-25 11:53:31.259286059 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #
+ # CORE
+ # Copyright (c) 2013 the Boeing Company.
+diff -Naur a/daemon/examples/findcore.py b/daemon/examples/findcore.py
+--- a/daemon/examples/findcore.py 2015-06-05 10:19:41.000000000 -0400
++++ b/daemon/examples/findcore.py 2015-06-25 11:53:31.259286059 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #
+ # Search for installed CORE library files and Python bindings.
+ #
+diff -Naur a/daemon/examples/stopsession.py b/daemon/examples/stopsession.py
+--- a/daemon/examples/stopsession.py 2015-06-05 10:19:41.000000000 -0400
++++ b/daemon/examples/stopsession.py 2015-06-25 11:53:31.259286059 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # (c)2010-2012 the Boeing Company
+ # author: Jeff Ahrenholz <jeffrey.m.ahrenholz@boeing.com>
+ #
+diff -Naur a/daemon/sbin/core-daemon b/daemon/sbin/core-daemon
+--- a/daemon/sbin/core-daemon 2015-06-05 10:19:41.000000000 -0400
++++ b/daemon/sbin/core-daemon 2015-06-25 11:53:31.259286059 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #
+ # CORE
+ # Copyright (c)2010-2013 the Boeing Company.
+diff -Naur a/daemon/sbin/core-manage b/daemon/sbin/core-manage
+--- a/daemon/sbin/core-manage 2015-06-05 10:19:41.000000000 -0400
++++ b/daemon/sbin/core-manage 2015-06-25 11:53:31.259286059 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #
+ # CORE
+ # Copyright (c)2014 the Boeing Company.
+diff -Naur a/daemon/sbin/coresendmsg b/daemon/sbin/coresendmsg
+--- a/daemon/sbin/coresendmsg 2015-06-05 10:19:41.000000000 -0400
++++ b/daemon/sbin/coresendmsg 2015-06-25 11:53:31.249286410 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #
+ # CORE
+ # Copyright (c)2011-2012 the Boeing Company.
+diff -Naur a/python-prefix.py b/python-prefix.py
+--- a/python-prefix.py 2015-06-05 10:19:41.000000000 -0400
++++ b/python-prefix.py 2015-06-25 11:53:31.249286410 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import sys
+ import os.path
+diff -Naur a/scripts/perf/perflogserver.py b/scripts/perf/perflogserver.py
+--- a/scripts/perf/perflogserver.py 2015-06-05 10:19:41.000000000 -0400
++++ b/scripts/perf/perflogserver.py 2015-06-25 11:53:31.249286410 -0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #
+ # (c)2011-2012 the Boeing Company
+ #