summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Wambold2020-05-13 09:43:56 -0400
committerTom Wambold2020-05-13 09:43:56 -0400
commitecdbb398c1ff51e98bc790e0ef608041b45aa3ea (patch)
treef31c301e0f6a80007e8bb60273061906f0fdf1b6
parentf58b09c7b3940f4e6e5f8f2f7c34315649172954 (diff)
downloadaur-ecdbb398c1ff51e98bc790e0ef608041b45aa3ea.tar.gz
Update to CORE 6.4.0 release.
* Disable Sphinx documentation, failed to build without custom theme package. * Remove python-sphinx dependency.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e628a9f750cc..0721f06cb006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = core
pkgdesc = Common Open Research Emulator
- pkgver = 6.3.0
+ pkgver = 6.4.0
pkgrel = 1
url = https://github.com/coreemu/core/
arch = i686
@@ -8,7 +8,6 @@ pkgbase = core
license = BSD
makedepends = help2man
makedepends = imagemagick
- makedepends = python-sphinx
makedepends = python-grpcio-tools
makedepends = openvswitch
depends = bridge-utils
@@ -33,8 +32,8 @@ pkgbase = core
depends = xterm
optdepends = openvswitch: Open vSwitch support
backup = etc/core/core.conf
- source = https://github.com/coreemu/core/archive/release-6.3.0.tar.gz
- md5sums = a20e285e77cc4282a503595181ab305d
+ source = https://github.com/coreemu/core/archive/release-6.4.0.tar.gz
+ md5sums = e3af7375a50547b7e7700095d829daf3
pkgname = core
diff --git a/PKGBUILD b/PKGBUILD
index 566fed9599e6..6ee97087bf0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tom Wambold <tom5760@gmail.com>
pkgname=core
-pkgver=6.3.0
+pkgver=6.4.0
pkgrel=1
pkgdesc="Common Open Research Emulator"
arch=('i686' 'x86_64')
@@ -10,12 +10,11 @@ depends=('bridge-utils' 'ebtables' 'ethtool' 'fabric' 'iproute2' 'libev'
'openvswitch' 'procps-ng' 'python3' 'python-future' 'python-grpcio'
'python-lxml' 'python-mako' 'python-netaddr' 'python-pillow' 'python-pyproj'
'python-yaml' 'tkimg' 'util-linux' 'xterm')
-makedepends=('help2man' 'imagemagick' 'python-sphinx' 'python-grpcio-tools'
- 'openvswitch')
+makedepends=('help2man' 'imagemagick' 'python-grpcio-tools' 'openvswitch')
optdepends=('openvswitch: Open vSwitch support')
backup=('etc/core/core.conf')
source=("https://github.com/coreemu/core/archive/release-$pkgver.tar.gz")
-md5sums=('a20e285e77cc4282a503595181ab305d')
+md5sums=('e3af7375a50547b7e7700095d829daf3')
build() {
cd "$srcdir/core-release-$pkgver"
@@ -23,8 +22,7 @@ build() {
./bootstrap.sh
./configure \
--prefix=/usr \
- --with-startup=systemd \
- --enable-docs
+ --with-startup=systemd
make
}