summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:24:48 +0530
committerlibrewish2020-01-24 23:24:48 +0530
commit6a3c10edbb96f517290c30ecde04282911cfad5d (patch)
treef84c8f9305c55e1d77b4e2de5b001d2c9ab29c78
downloadaur-6a3c10edbb96f517290c30ecde04282911cfad5d.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b719efa9d6e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = coreaction-git
+ pkgdesc = A side bar for showing widgets from the CoreApps family.
+ pkgver = v2.8.0.r1.a796070
+ pkgrel = 1
+ url = https://gitlab.com/cubocore
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = GPL3
+ makedepends = git
+ depends = libcprime-git
+ depends = libcsys-git
+ depends = qt5-svg
+ provides = coreaction
+ conflicts = coreaction
+ source = git+https://gitlab.com/cubocore/coreaction.git
+ md5sums = SKIP
+
+pkgname = coreaction-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f62b65b81778
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=coreaction
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r1.a796070
+pkgrel=1
+pkgdesc="A side bar for showing widgets from the CoreApps family."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore"
+license=('GPL3')
+depends=('libcprime-git' 'libcsys-git' 'qt5-svg' )
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}