summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2020-09-11 10:58:03 -0700
committerAnatol Pomozov2020-09-11 10:58:03 -0700
commit350d2d35fef6e4993cb1cdddf071fd9aaf5ac0dd (patch)
treed6f17ac3c138011c2f501bdc1e744f433d2bd233
parent5b247a3fa38bd7192af06d1b680b0418df6b2f0a (diff)
downloadaur-350d2d35fef6e4993cb1cdddf071fd9aaf5ac0dd.tar.gz
Version bump, fix the build
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD49
2 files changed, 34 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb27f6992c5e..57a50948e2d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = coreboot-utils-git
pkgdesc = Tools and utilities to work with coreboot firmware
- pkgver = 4.11.r760.gc2ce370f30b
+ pkgver = 4.12.r2683.g8e1ea525d1e
pkgrel = 1
url = https://www.coreboot.org/
- arch = i686
arch = x86_64
license = GPL
makedepends = git
@@ -23,6 +22,9 @@ pkgbase = coreboot-utils-git
source = git+https://review.coreboot.org/intel-microcode
source = git+https://review.coreboot.org/ffs
source = git+https://review.coreboot.org/amd_blobs
+ source = git+https://review.coreboot.org/cmocka
+ source = git+https://review.coreboot.org/qc_blobs
+ source = git+https://review.coreboot.org/9esec-security-tooling
source = autoport-tool-paths.patch
sha256sums = SKIP
sha256sums = SKIP
@@ -37,7 +39,9 @@ pkgbase = coreboot-utils-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 5136f8ae6c690501b483243a33b91dc978971cf23bcf48c27bdca845db53bdb1
pkgname = coreboot-utils-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 32aff580fb60..9bea81188d04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,31 @@
# Maintainer: Iru Cai <mytbk920423@gmail.com>
pkgname=coreboot-utils-git
-pkgver=4.11.r760.gc2ce370f30b
+pkgver=4.12.r2683.g8e1ea525d1e
pkgrel=1
pkgdesc='Tools and utilities to work with coreboot firmware'
url='https://www.coreboot.org/'
license=(GPL)
-arch=(i686 x86_64)
+arch=(x86_64)
depends=(pciutils)
optdepends=("python: me_cleaner support")
makedepends=(git)
source=(git+https://review.coreboot.org/coreboot
- git+https://review.coreboot.org/blobs
- git+https://review.coreboot.org/nvidia-cbootimage
- git+https://review.coreboot.org/vboot
- git+https://review.coreboot.org/arm-trusted-firmware
- git+https://review.coreboot.org/chrome-ec
- git+https://review.coreboot.org/libhwbase
- git+https://review.coreboot.org/libgfxinit
- git+https://review.coreboot.org/fsp
- git+https://review.coreboot.org/opensbi
- git+https://review.coreboot.org/intel-microcode
- git+https://review.coreboot.org/ffs
- git+https://review.coreboot.org/amd_blobs
+ git+https://review.coreboot.org/blobs
+ git+https://review.coreboot.org/nvidia-cbootimage
+ git+https://review.coreboot.org/vboot
+ git+https://review.coreboot.org/arm-trusted-firmware
+ git+https://review.coreboot.org/chrome-ec
+ git+https://review.coreboot.org/libhwbase
+ git+https://review.coreboot.org/libgfxinit
+ git+https://review.coreboot.org/fsp
+ git+https://review.coreboot.org/opensbi
+ git+https://review.coreboot.org/intel-microcode
+ git+https://review.coreboot.org/ffs
+ git+https://review.coreboot.org/amd_blobs
+ git+https://review.coreboot.org/cmocka
+ git+https://review.coreboot.org/qc_blobs
+ git+https://review.coreboot.org/9esec-security-tooling
# vboot provides vb2_api.h needed by cbfstool
autoport-tool-paths.patch)
sha256sums=('SKIP'
@@ -39,12 +42,15 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'5136f8ae6c690501b483243a33b91dc978971cf23bcf48c27bdca845db53bdb1')
BUILD_AUTOPORT=y
if [ "$BUILD_AUTOPORT" == y ]; then
- makedepends=("${makedepends[@]}" go)
+ makedepends=("${makedepends[@]}" go)
fi
pkgver() {
@@ -55,10 +61,6 @@ pkgver() {
prepare() {
cd coreboot
- # for some reason 'git submodule ...' fails with 'No url found for submodule path 'coreboot' in .gitmodules'
- # here is workaround that seems fixes the issue
- git rm -rf coreboot || true
-
git config -f .gitmodules 'submodule.3rdparty/blobs.url' "$srcdir/blobs"
git config -f .gitmodules 'submodule.util/nvidia-cbootimage.url' "$srcdir/nvidia-cbootimage"
git config -f .gitmodules 'submodule.vboot.url' "$srcdir/vboot"
@@ -71,6 +73,9 @@ prepare() {
git config -f .gitmodules 'submodule.intel-microcode.url' "$srcdir/intel-microcode"
git config -f .gitmodules 'submodule.3rdparty/ffs.url' "$srcdir/ffs"
git config -f .gitmodules 'submodule.3rdparty/amd_blobs.url' "$srcdir/amd_blobs"
+ git config -f .gitmodules 'submodule.3rdparty/cmocka.url' "$srcdir/cmocka"
+ git config -f .gitmodules 'submodule.3rdparty/qc_blobs.url' "$srcdir/qc_blobs"
+ git config -f .gitmodules 'submodule.3rdparty/intel-sec-tools.url' "$srcdir/9esec-security-tooling"
git submodule update --init
@@ -90,8 +95,8 @@ build() {
make -C ectool
make -C intelvbttool
if [ "$BUILD_AUTOPORT" == y ]; then
- cd autoport
- go build
+ cd autoport
+ go build
fi
}
@@ -101,7 +106,7 @@ package() {
install -m755 -t "$pkgdir/usr/bin" cbfstool/{cbfstool,rmodtool} ifdtool/ifdtool nvramtool/nvramtool inteltool/inteltool superiotool/superiotool cbmem/cbmem ectool/ectool intelmetool/intelmetool intelvbttool/intelvbttool
install -m755 "me_cleaner/me_cleaner.py" "$pkgdir/usr/bin/me_cleaner"
if [ "$BUILD_AUTOPORT" == y ]; then
- install -m755 -t "$pkgdir/usr/bin" autoport/autoport
+ install -m755 -t "$pkgdir/usr/bin" autoport/autoport
fi
install -m644 -t "$pkgdir"/usr/share/man/man8 inteltool/inteltool.8