summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2019-04-25 11:45:45 -0700
committerAnatol Pomozov2019-04-25 11:46:01 -0700
commit4a643cc4c7c1ecb3ad5c672a7cd4b950c0dedf89 (patch)
tree7d7959a19ca34dfbce8a3c2c0f643b2666994667
parent4acfbe8d0933305829f34eb592937f146f080df7 (diff)
downloadaur-4a643cc4c7c1ecb3ad5c672a7cd4b950c0dedf89.tar.gz
fix the build and update to top-of-the-tree
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 48 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 524518d09857..f7fa5bd27373 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = coreboot-utils-git
pkgdesc = Tools and utilities to work with coreboot firmware
- pkgver = 4.8.r2370.gaaced4a932d
+ pkgver = 4.9.r1437.g74f9fe6e58f
pkgrel = 1
url = https://www.coreboot.org/
arch = i686
@@ -11,10 +11,26 @@ pkgbase = coreboot-utils-git
depends = pciutils
optdepends = python: me_cleaner support
source = git+https://review.coreboot.org/coreboot
+ source = git+https://review.coreboot.org/blobs
+ source = git+https://review.coreboot.org/nvidia-cbootimage
source = git+https://review.coreboot.org/vboot
+ source = git+https://review.coreboot.org/arm-trusted-firmware
+ source = git+https://review.coreboot.org/chrome-ec
+ source = git+https://review.coreboot.org/libhwbase
+ source = git+https://review.coreboot.org/libgfxinit
+ source = git+https://review.coreboot.org/fsp
+ source = git+https://review.coreboot.org/opensbi
source = autoport-tool-paths.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 5136f8ae6c690501b483243a33b91dc978971cf23bcf48c27bdca845db53bdb1
pkgname = coreboot-utils-git
diff --git a/PKGBUILD b/PKGBUILD
index 08dd7b4e0e0b..ae9269de0197 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Iru Cai <mytbk920423@gmail.com>
pkgname=coreboot-utils-git
-pkgver=4.8.r2370.gaaced4a932d
+pkgver=4.9.r1437.g74f9fe6e58f
pkgrel=1
pkgdesc='Tools and utilities to work with coreboot firmware'
url='https://www.coreboot.org/'
@@ -12,11 +12,27 @@ depends=(pciutils)
optdepends=("python: me_cleaner support")
makedepends=(git)
source=(git+https://review.coreboot.org/coreboot
+ git+https://review.coreboot.org/blobs
+ git+https://review.coreboot.org/nvidia-cbootimage
+ git+https://review.coreboot.org/vboot
+ git+https://review.coreboot.org/arm-trusted-firmware
+ git+https://review.coreboot.org/chrome-ec
+ git+https://review.coreboot.org/libhwbase
+ git+https://review.coreboot.org/libgfxinit
+ git+https://review.coreboot.org/fsp
+ git+https://review.coreboot.org/opensbi
# vboot provides vb2_api.h needed by cbfstool
- git+https://review.coreboot.org/vboot
autoport-tool-paths.patch)
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'5136f8ae6c690501b483243a33b91dc978971cf23bcf48c27bdca845db53bdb1')
BUILD_AUTOPORT=y
@@ -33,10 +49,20 @@ pkgver() {
prepare() {
cd coreboot
- git submodule init
+ # coreboot repo seems screwed https://stackoverflow.com/questions/4185365/no-submodule-mapping-found-in-gitmodule-for-a-path-thats-not-a-submodule
+ git rm -rf coreboot
+
+ git config -f .gitmodules 'submodule.3rdparty/blobs.url' "$srcdir/blobs"
+ git config -f .gitmodules 'submodule.util/nvidia-cbootimage.url' "$srcdir/nvidia-cbootimage"
git config -f .gitmodules 'submodule.vboot.url' "$srcdir/vboot"
- git submodule sync -- 3rdparty/vboot
- git submodule update -- 3rdparty/vboot
+ git config -f .gitmodules 'submodule.arm-trusted-firmware.url' "$srcdir/arm-trusted-firmware"
+ git config -f .gitmodules 'submodule.3rdparty/chromeec.url' "$srcdir/chrome-ec"
+ git config -f .gitmodules 'submodule.libhwbase.url' "$srcdir/libhwbase"
+ git config -f .gitmodules 'submodule.libgfxinit.url' "$srcdir/libgfxinit"
+ git config -f .gitmodules 'submodule.3rdparty/fsp.url' "$srcdir/fsp"
+ git config -f .gitmodules 'submodule.opensbi.url' "$srcdir/opensbi"
+
+ git submodule update --init
patch -p1 -i "$srcdir/autoport-tool-paths.patch"
}