summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2016-08-29 01:57:30 +0800
committerIru Cai2016-08-29 01:57:30 +0800
commitf62b5d803ec4062b3acc5e08f5f3cc9cbfa48d3b (patch)
treeb46aa50ad7b873099750de82eb60515267a8939a
parentc97b4a86dda8871e9b81e9cb97666a61dbbca550 (diff)
downloadaur-f62b5d803ec4062b3acc5e08f5f3cc9cbfa48d3b.tar.gz
remove unneeded submodules
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 069a81d8d88c..467302780e97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,16 +10,9 @@ arch=(i686 x86_64)
depends=(glibc)
makedepends=(git)
source=(git+https://review.coreboot.org/coreboot
- git+https://review.coreboot.org/chrome-ec
- git+https://review.coreboot.org/vboot
- git+https://review.coreboot.org/blobs
- git+https://review.coreboot.org/nvidia-cbootimage
- git+https://review.coreboot.org/arm-trusted-firmware)
+ # vboot provides vb2_api.h needed by cbfstool
+ git+https://review.coreboot.org/vboot)
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -31,13 +24,9 @@ prepare() {
cd coreboot
git submodule init
- git config -f .gitmodules 'submodule.3rdparty/blobs.url' "$srcdir/blobs"
- git config -f .gitmodules 'submodule.3rdparty/chromeec.url' "$srcdir/chrome-ec"
- git config -f .gitmodules 'submodule.util/nvidia-cbootimage.url' "$srcdir/nvidia-cbootimage"
git config -f .gitmodules 'submodule.vboot.url' "$srcdir/vboot"
- git config -f .gitmodules 'submodule.arm-trusted-firmware.url' "$srcdir/arm-trusted-firmware"
- git submodule sync
- git submodule update
+ git submodule sync -- 3rdparty/vboot
+ git submodule update -- 3rdparty/vboot
}
build() {