summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2015-02-10 16:45:39 +0200
committerYuval Adam2015-02-10 16:45:39 +0200
commit8b92df324b8c544f8d83032fff1ef02eb92cef9b (patch)
treece85f0b187c7b481b2fba9bd29d50281f1131585
downloadaur-8b92df324b8c544f8d83032fff1ef02eb92cef9b.tar.gz
Add coreclr-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cabf86346dfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = coreclr-git
+ pkgdesc = The .NET Core Runtime
+ pkgver = d921298
+ pkgrel = 1
+ url = https://github.com/dotnet/coreclr
+ arch = x86_64
+ license = MIT
+ makedepends = clang cmake
+ provides = coreclr
+ source = git+https://github.com/dotnet/coreclr
+ sha1sums = SKIP
+
+pkgname = coreclr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..604ec75302d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+
+pkgname=coreclr-git
+pkgver=d921298
+pkgrel=1
+pkgdesc="The .NET Core Runtime"
+arch=('x86_64')
+url="https://github.com/dotnet/coreclr"
+license=(MIT)
+makedepends=('clang cmake')
+provides=('coreclr')
+source=('git+https://github.com/dotnet/coreclr')
+sha1sums=('SKIP')
+_gitname=coreclr
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname
+ ./build.sh
+}
+
+package() {
+ install -Dm755 ${srcdir}/${_gitname}/binaries/Product/amd64/debug/corerun ${pkgdir}/usr/bin/corerun
+ install -d ${pkgdir}/usr/{lib,include}
+ install ${srcdir}/${_gitname}/binaries/Product/amd64/debug/*.so ${pkgdir}/usr/lib/
+ install ${srcdir}/${_gitname}/binaries/Product/amd64/debug/inc/*.h ${pkgdir}/usr/include/
+}
+
+# vim:set ts=2 sw=2 et: