summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormurlakatamenka2020-06-08 18:06:17 +0300
committermurlakatamenka2020-06-08 18:06:17 +0300
commit83fe7c169284956e025ab5e80dddba5d28273c03 (patch)
tree4afb67cd308c26483dc63475930e071073f92f38
parent78a94b10c1f6a7c38e4dfa225506714ef8140189 (diff)
downloadaur-83fe7c169284956e025ab5e80dddba5d28273c03.tar.gz
Add missing dependencies; refactor a bit
Thanks to u666sa for pointing out missing dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e31703437d..f4a113343ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = corectrl-git
pkgdesc = Application to control your hardware with ease using application profiles
- pkgver = 1.0.3.r0.gf142706
- pkgrel = 2
+ pkgver = 1.0.3.r128.g2aacf49
+ pkgrel = 1
url = https://gitlab.com/corectrl/corectrl
arch = i686
arch = x86_64
@@ -11,14 +11,16 @@ pkgbase = corectrl-git
makedepends = extra-cmake-modules
makedepends = gcc>=8
makedepends = qt5-tools
- depends = procps-ng
- depends = hwids
depends = botan>=2.2.0
depends = qt5-base>=5.9
depends = qt5-quickcontrols2
depends = qt5-charts
+ depends = qt5-svg
+ depends = qt5-xmlpatterns
depends = kauth
depends = karchive
+ depends = procps-ng
+ depends = hwids
optdepends = vulkan-tools: for vulkaninfo
optdepends = mesa-demos: for glxinfo
optdepends = util-linux: for lscpu
diff --git a/PKGBUILD b/PKGBUILD
index dcb778a42f9..836547a16c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# based off `corectrl` PKGBUILD by Sergey Kostyuchenko <derfenix@gmail.com>
_pkgname=corectrl
-pkgname="$_pkgname-git"
-pkgver=1.0.3.r25.g20db8ac
-pkgrel=2
+pkgname=${_pkgname}-git
+pkgver=1.0.3.r128.g2aacf49
+pkgrel=1
pkgdesc="Application to control your hardware with ease using application profiles"
url="https://gitlab.com/corectrl/corectrl"
-license=('GPL3')
-arch=('i686' 'x86_64')
-depends=('botan>=2.2.0' 'qt5-base>=5.9' 'qt5-quickcontrols2' 'qt5-charts' 'kauth' 'karchive' 'procps-ng' 'hwids')
-makedepends=('git' 'cmake>=3.3' 'extra-cmake-modules' 'gcc>=8' 'qt5-tools')
+license=(GPL3)
+arch=(i686 x86_64)
+depends=('botan>=2.2.0' 'qt5-base>=5.9' qt5-quickcontrols2 qt5-charts qt5-svg qt5-xmlpatterns kauth karchive procps-ng hwids)
+makedepends=(git 'cmake>=3.3' extra-cmake-modules 'gcc>=8' qt5-tools)
optdepends=(
'vulkan-tools: for vulkaninfo'
'mesa-demos: for glxinfo'