summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTommy Hudson2021-08-17 11:11:45 +0100
committerTommy Hudson2021-08-17 11:43:42 +0100
commiteb205891cd1143365822279d2389d980027a0ee0 (patch)
treecc80a90fc5ffc05822a52e5f01e03fd39dc45b04
parent83fe7c169284956e025ab5e80dddba5d28273c03 (diff)
downloadaur-eb205891cd1143365822279d2389d980027a0ee0.tar.gz
Patch out fan control when in automatic mode
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
-rw-r--r--dont-mess-with-fans.patch13
3 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4a113343ae7..ee7fd6f20502 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = corectrl-git
+pkgbase = corectrl-nofan-git
pkgdesc = Application to control your hardware with ease using application profiles
- pkgver = 1.0.3.r128.g2aacf49
+ pkgver = 1.0.3.r174.g5ab63d3
pkgrel = 1
url = https://gitlab.com/corectrl/corectrl
arch = i686
@@ -27,7 +27,8 @@ pkgbase = corectrl-git
provides = corectrl
conflicts = corectrl
source = git+https://gitlab.com/corectrl/corectrl.git
+ source = dont-mess-with-fans.patch
md5sums = SKIP
+ md5sums = 990ff598ac4d837c4cd2f4213d164730
-pkgname = corectrl-git
-
+pkgname = corectrl-nofan-git
diff --git a/PKGBUILD b/PKGBUILD
index 836547a16c88..711d094e15f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Sergey A. <murlakatamenka@disroot.org>
+# Maintainer: Tommy Hudson <thomhuds@protonmail.com>
+# Contributor: Sergey A. <murlakatamenka@disroot.org>
# based off `corectrl` PKGBUILD by Sergey Kostyuchenko <derfenix@gmail.com>
_pkgname=corectrl
-pkgname=${_pkgname}-git
-pkgver=1.0.3.r128.g2aacf49
+pkgname=${_pkgname}-nofan-git
+pkgver=1.0.3.r174.g5ab63d3
pkgrel=1
pkgdesc="Application to control your hardware with ease using application profiles"
url="https://gitlab.com/corectrl/corectrl"
@@ -18,14 +19,19 @@ optdepends=(
)
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+$url.git")
-md5sums=('SKIP')
+source=("git+$url.git" "dont-mess-with-fans.patch")
+md5sums=('SKIP' '990ff598ac4d837c4cd2f4213d164730')
pkgver() {
cd "$srcdir/$_pkgname"
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ patch --forward --strip=1 --input="${srcdir}/dont-mess-with-fans.patch"
+}
+
build() {
cd "$srcdir/$_pkgname"
mkdir build
diff --git a/dont-mess-with-fans.patch b/dont-mess-with-fans.patch
new file mode 100644
index 000000000000..d2b225c85ebb
--- /dev/null
+++ b/dont-mess-with-fans.patch
@@ -0,0 +1,13 @@
+diff --git a/src/core/components/controls/amd/fan/auto/fanauto.cpp b/src/core/components/controls/amd/fan/auto/fanauto.cpp
+index 021d6aa..7ea6062 100644
+--- a/src/core/components/controls/amd/fan/auto/fanauto.cpp
++++ b/src/core/components/controls/amd/fan/auto/fanauto.cpp
+@@ -59,8 +59,4 @@ void AMD::FanAuto::cleanControl(ICommandQueue &)
+
+ void AMD::FanAuto::syncControl(ICommandQueue &ctlCmds)
+ {
+- if (dataSource_->read(pwmEnable_)) {
+- if (pwmEnable_ != 2)
+- ctlCmds.add({dataSource_->source(), "2"});
+- }
+ }