summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Fontana2018-03-29 23:58:02 +0200
committerLorenzo Fontana2018-03-29 23:58:02 +0200
commit33717982d0147e9c5cc3a84624d536b01ff85df2 (patch)
treef912c291ed2078ffd406d1f1fc18cc8148306c08
downloadaur-33717982d0147e9c5cc3a84624d536b01ff85df2.tar.gz
Version: v1.1.1
Signed-off-by: Lorenzo Fontana <lo@linux.com>
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
-rw-r--r--coredns.service20
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f79e97ab394
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = coredns-bin
+ pkgdesc = CoreDNS is a DNS server that chains plugins (official binary version)
+ pkgver = v1.1.1
+ pkgrel = 1
+ url = https://github.com/coredns/coredns
+ arch = x86_64
+ license = Apache
+ provides = coredns
+ source = coredns_x64_v1.1.1.tar.gz::https://github.com/coredns/coredns/releases/download/v1.1.1/coredns_1.1.1_linux_amd64.tgz
+ source = https://raw.githubusercontent.com/coredns/deployment/5bb111266eca2d47802e0d1a26bc55491ff2cec3/systemd/coredns.service
+ sha256sums = 6e2367879163b1c9036d5c69a121e81bad628944b9b395f49a6e45a2d9d420dd
+ sha256sums = be3eb5ce8740b17053aaf04ca036a4d34e0b86d0737253be7094cda16a329cf5
+
+pkgname = coredns-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..53aff0a6cc68
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz*
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f9e21836fb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Lorenzo Fontana <lo@linux.com>
+pkgname=coredns-bin
+pkgver=v1.1.1
+pkgrel=1
+pkgdesc="CoreDNS is a DNS server that chains plugins (official binary version)"
+arch=('x86_64')
+url="https://github.com/coredns/coredns"
+license=('Apache')
+provides=('coredns')
+source=(coredns_x64_${pkgver}.tar.gz::https://github.com/coredns/coredns/releases/download/${pkgver}/coredns_1.1.1_linux_amd64.tgz
+https://raw.githubusercontent.com/coredns/deployment/5bb111266eca2d47802e0d1a26bc55491ff2cec3/systemd/coredns.service)
+
+sha256sums=('6e2367879163b1c9036d5c69a121e81bad628944b9b395f49a6e45a2d9d420dd'
+'be3eb5ce8740b17053aaf04ca036a4d34e0b86d0737253be7094cda16a329cf5')
+
+package() {
+ install -Dm755 "$srcdir/coredns" "$pkgdir/usr/bin/coredns"
+ install -Dm644 "$srcdir/coredns.service" "$pkgdir/usr/lib/systemd/system/coredns.service"
+ install -d "${pkgdir}/etc/coredns"
+}
diff --git a/coredns.service b/coredns.service
new file mode 100644
index 000000000000..9fa21a751a7d
--- /dev/null
+++ b/coredns.service
@@ -0,0 +1,20 @@
+[Unit]
+Description=CoreDNS DNS server
+Documentation=https://coredns.io
+After=network.target
+
+[Service]
+PermissionsStartOnly=true
+LimitNOFILE=1048576
+LimitNPROC=512
+CapabilityBoundingSet=CAP_NET_BIND_SERVICE
+AmbientCapabilities=CAP_NET_BIND_SERVICE
+NoNewPrivileges=true
+User=coredns
+WorkingDirectory=~
+ExecStart=/usr/bin/coredns -conf=/etc/coredns/Corefile
+ExecReload=/bin/kill -SIGUSR1 $MAINPID
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target