summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:29:04 +0530
committerlibrewish2020-01-24 23:29:04 +0530
commit11d20bdbe68d1ee10aed3da6ff8270e32f490701 (patch)
treefefdca100da4318690acbe40f4c160d3a62e0e4d
downloadaur-11d20bdbe68d1ee10aed3da6ff8270e32f490701.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7ccc57bdf68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = corefm-git
+ pkgdesc = A lightwight filemanager from the CoreApps family.
+ pkgver = v2.8.0.r6.2dc8b59
+ pkgrel = 1
+ url = https://gitlab.com/cubocore
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = GPL3
+ makedepends = git
+ depends = libcprime-git
+ depends = libcsys-git
+ depends = qt5-multimedia
+ provides = corefm
+ conflicts = corefm
+ source = git+https://gitlab.com/cubocore/corefm.git
+ md5sums = SKIP
+
+pkgname = corefm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f4032eff1c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=corefm
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r6.2dc8b59
+pkgrel=1
+pkgdesc="A lightwight filemanager from the CoreApps family."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore"
+license=('GPL3')
+depends=('libcprime-git' 'libcsys-git' 'qt5-multimedia')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}