summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:30:28 +0530
committerlibrewish2020-01-24 23:30:28 +0530
commitfd39a2e1af2828425065460a2d86674e8a962f94 (patch)
treebe1c74c6cd37be5b28d2e02dcf6a9a46ef7ef700
downloadaur-fd39a2e1af2828425065460a2d86674e8a962f94.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e8a176b2b73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = corehunt-git
+ pkgdesc = A file finder utility from the CoreApps family.
+ pkgver = v2.8.0.r1.8da2e56
+ pkgrel = 1
+ url = https://gitlab.com/cubocore
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = GPL3
+ makedepends = git
+ depends = libcprime-git
+ provides = corehunt
+ conflicts = corehunt
+ source = git+https://gitlab.com/cubocore/corehunt.git
+ md5sums = SKIP
+
+pkgname = corehunt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd648b08bc59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=corehunt
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r1.8da2e56
+pkgrel=1
+pkgdesc="A file finder utility from the CoreApps family."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore"
+license=('GPL3')
+depends=('libcprime-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}