summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2019-09-16 15:29:22 +0200
committerDan Johansen2019-09-16 15:29:22 +0200
commitb1ab7bf94d95f5328a2e6b9422fff1d13b65aac5 (patch)
tree6287035e107deb9721a4594dc936b945ad5cfae9
downloadaur-b1ab7bf94d95f5328a2e6b9422fff1d13b65aac5.tar.gz
initial commit, version 2.7
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fdc0ac850c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = corekeyboard
+ pkgdesc = A virtual keyboard for X11 from the CoreApps family.
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = https://gitlab.com/cubocore/corekeyboard
+ arch = x86_64
+ arch = aarch64
+ groups = coreapps
+ license = GPL3
+ depends = qt5-base
+ depends = libcprime
+ depends = qt5-x11extras
+ depends = libxtst
+ depends = libx11
+ source = https://gitlab.com/cubocore/corekeyboard/-/archive/v2.7.0/corekeyboard-v2.7.0.tar.gz
+ md5sums = edba5959424384cd54fd034d510a28b7
+
+pkgname = corekeyboard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71a6c36eaa90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Shaber
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+pkgname=corekeyboard
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="A virtual keyboard for X11 from the CoreApps family."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/cubocore/$pkgname"
+license=('GPL3')
+depends=('qt5-base' 'libcprime' 'qt5-x11extras' 'libxtst' 'libx11')
+groups=('coreapps')
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('edba5959424384cd54fd034d510a28b7')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd ${pkgname}-v${pkgver}
+
+ qmake-qt5 ${pkgname}.pro
+ make
+}
+
+package() {
+ cd ${pkgname}-v${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+}