summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2019-09-18 16:08:05 +0200
committerDan Johansen2019-09-18 16:08:05 +0200
commit0b3a33a02a9946e56716770aea2af2b56994b484 (patch)
tree0bc003e1ead26eac9e5b0e44b286f7a7acb873ea
parent9995c43cdbae6f2c497ae0d45fcf2d69ed5ed377 (diff)
downloadaur-0b3a33a02a9946e56716770aea2af2b56994b484.tar.gz
added desktop and icon files, until its fixed in upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--corepdf.desktop10
-rw-r--r--corepdf.svg228
4 files changed, 252 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39c6bf5e1276..fa2180493f66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = corepdf
pkgdesc = A PDF viewer from the CoreApps family.
pkgver = 2.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/cubocore/corepdf
arch = x86_64
arch = aarch64
@@ -11,7 +11,11 @@ pkgbase = corepdf
depends = poppler-qt5
depends = libcprime
source = https://gitlab.com/cubocore/corepdf/-/archive/v2.7.0/corepdf-v2.7.0.tar.gz
+ source = corepdf.desktop
+ source = corepdf.svg
md5sums = f081935f61c62381f23daf30b7a198b4
+ md5sums = a41a609862a5713ba152474837e3187e
+ md5sums = 8c67a9f44d0f7078ed023de96d26adab
pkgname = corepdf
diff --git a/PKGBUILD b/PKGBUILD
index fef965b059d5..67583673619b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,19 @@
pkgname=corepdf
pkgver=2.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="A PDF viewer from the CoreApps family."
arch=('x86_64' 'aarch64')
url="https://gitlab.com/cubocore/$pkgname"
license=('GPL3')
depends=('qt5-base' 'poppler-qt5' 'libcprime')
groups=('coreapps')
-source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-md5sums=('f081935f61c62381f23daf30b7a198b4')
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+ 'corepdf.desktop'
+ 'corepdf.svg')
+md5sums=('f081935f61c62381f23daf30b7a198b4'
+ 'a41a609862a5713ba152474837e3187e'
+ '8c67a9f44d0f7078ed023de96d26adab')
prepare() {
mkdir -p build
@@ -27,4 +31,6 @@ build() {
package() {
cd ${pkgname}-v${pkgver}
make INSTALL_ROOT=${pkgdir} install
+ install -Dm644 "../corepdf.desktop" -t "${pkgdir}/usr/share/applications/"
+ install -Dm644 "../corepdf.svg" -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps/"
}
diff --git a/corepdf.desktop b/corepdf.desktop
new file mode 100644
index 000000000000..a96c2c25bc9e
--- /dev/null
+++ b/corepdf.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=CorePDF
+Comment=A PDF viewer for CuboCore Application Suite.
+Exec=corepdf %f
+Icon=/usr/share/icons/hicolor/scalable/apps/corepdf.svg
+Type=Application
+Categories=Qt;Office;
+Terminal=false
+StartupNotify=true
+MimeType=application/pdf; \ No newline at end of file
diff --git a/corepdf.svg b/corepdf.svg
new file mode 100644
index 000000000000..59c38faade7a
--- /dev/null
+++ b/corepdf.svg
@@ -0,0 +1,228 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ id="svg2"
+ version="1.1"
+ inkscape:version="0.48.5 r10040"
+ width="513"
+ height="513"
+ sodipodi:docname="fbreader.svg">
+ <metadata
+ id="metadata8">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <defs
+ id="defs6" />
+ <sodipodi:namedview
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1"
+ objecttolerance="10"
+ gridtolerance="10"
+ guidetolerance="10"
+ inkscape:pageopacity="0"
+ inkscape:pageshadow="2"
+ inkscape:window-width="1366"
+ inkscape:window-height="716"
+ id="namedview4"
+ showgrid="false"
+ inkscape:zoom="0.65059337"
+ inkscape:cx="780.38563"
+ inkscape:cy="124.82629"
+ inkscape:window-x="0"
+ inkscape:window-y="0"
+ inkscape:window-maximized="1"
+ inkscape:current-layer="svg2" />
+ <rect
+ style="fill:#f03916;fill-opacity:1;stroke:none"
+ id="rect2993-9-3"
+ width="225.05569"
+ height="343.12222"
+ x="-473.73657"
+ y="90.898361"
+ ry="41.696136"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#e6e6e6;fill-opacity:1;stroke:none"
+ id="rect2993-3"
+ width="203.70166"
+ height="310.67706"
+ x="249.71867"
+ y="109.00687"
+ ry="0" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781"
+ width="160.6637"
+ height="5.0842938"
+ x="269.71249"
+ y="142.18103"
+ ry="2.5421469" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-6"
+ width="160.6637"
+ height="5.0842938"
+ x="270.51862"
+ y="174.0569"
+ ry="2.5421469" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-7"
+ width="160.6637"
+ height="5.0842938"
+ x="269.79971"
+ y="207.85121"
+ ry="2.5421469" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-5"
+ width="160.6637"
+ height="5.0842938"
+ x="270.11548"
+ y="244.0428"
+ ry="2.5421469" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-6-3"
+ width="160.6637"
+ height="5.0842938"
+ x="270.9216"
+ y="275.91867"
+ ry="2.5421469" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-7-5"
+ width="160.6637"
+ height="5.0842938"
+ x="270.2027"
+ y="309.71298"
+ ry="2.5421469" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-6-3-6"
+ width="160.6637"
+ height="5.0842938"
+ x="271.59705"
+ y="345.54501"
+ ry="2.5421469" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-7-5-2"
+ width="160.6637"
+ height="5.0842938"
+ x="270.87814"
+ y="379.33932"
+ ry="2.5421469" />
+ <rect
+ style="fill:#f03916;fill-opacity:1;stroke:none"
+ id="rect2993-9"
+ width="225.05569"
+ height="343.12222"
+ x="-250.05569"
+ y="89.529991"
+ ry="41.696136"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#e6e6e6;fill-opacity:1;stroke:none"
+ id="rect2993-3-1"
+ width="203.70166"
+ height="310.67706"
+ x="-250.28134"
+ y="107.89968"
+ ry="0"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-2"
+ width="160.6637"
+ height="5.0842938"
+ x="-230.28751"
+ y="141.07385"
+ ry="2.5421469"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-6-7"
+ width="160.6637"
+ height="5.0842938"
+ x="-229.48138"
+ y="172.94972"
+ ry="2.5421469"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-7-0"
+ width="160.6637"
+ height="5.0842938"
+ x="-230.20029"
+ y="206.74403"
+ ry="2.5421469"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-5-9"
+ width="160.6637"
+ height="5.0842938"
+ x="-229.88454"
+ y="242.93562"
+ ry="2.5421469"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-6-3-3"
+ width="160.6637"
+ height="5.0842938"
+ x="-229.07841"
+ y="274.81149"
+ ry="2.5421469"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-7-5-6"
+ width="160.6637"
+ height="5.0842938"
+ x="-229.79732"
+ y="308.6058"
+ ry="2.5421469"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-6-3-6-0"
+ width="160.6637"
+ height="5.0842938"
+ x="-228.40297"
+ y="344.43784"
+ ry="2.5421469"
+ transform="scale(-1,1)" />
+ <rect
+ style="fill:#999999;fill-opacity:1;stroke:none"
+ id="rect3781-7-5-2-6"
+ width="160.6637"
+ height="5.0842938"
+ x="-229.12186"
+ y="378.23215"
+ ry="2.5421469"
+ transform="scale(-1,1)" />
+ <path
+ style="fill:#ff6600;stroke:none"
+ d="m 399.35762,107.81912 -0.50411,172.6547 -29.99735,-23.89618 -30.50574,22.87932 1.01684,-170.83228 z"
+ id="path3922"
+ inkscape:connector-curvature="0" />
+</svg>