summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:36:26 +0530
committerlibrewish2020-01-24 23:36:26 +0530
commit16d05b8c667e77388e9626304812418dc8eabaff (patch)
tree2c1885f932a697a841c3a1ea6b37d94e55a26280
downloadaur-16d05b8c667e77388e9626304812418dc8eabaff.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a36fd55cf0b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = coreshot-git
+ pkgdesc = A screen capture utility from the CoreApps family.
+ pkgver = v2.8.0.r0.341bef9
+ pkgrel = 1
+ url = https://gitlab.com/cubocore
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = GPL3
+ makedepends = git
+ depends = qt5-x11extras
+ depends = libcprime-git
+ provides = coreshot
+ conflicts = coreshot
+ source = git+https://gitlab.com/cubocore/coreshot.git
+ md5sums = SKIP
+
+pkgname = coreshot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f54927d0345
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=coreshot
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r0.341bef9
+pkgrel=1
+pkgdesc="A screen capture utility from the CoreApps family."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore"
+license=('GPL3')
+depends=('qt5-x11extras' 'libcprime-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}