summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2019-09-16 15:26:49 +0200
committerDan Johansen2019-09-16 15:26:49 +0200
commit40712d6f02c93241034ac7370e512489c0432804 (patch)
tree7fc549faaaea7d1c0cc544bac2827c2011c98cce
downloadaur-40712d6f02c93241034ac7370e512489c0432804.tar.gz
initial commit, version 2.7
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9adf9254b42e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = corestats
+ pkgdesc = A system resource viewer from the CoreApps family.
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = https://gitlab.com/cubocore/corestats
+ arch = x86_64
+ arch = aarch64
+ groups = coreapps
+ license = GPL3
+ depends = qt5-base
+ depends = libcprime
+ depends = libcsys
+ source = https://gitlab.com/cubocore/corestats/-/archive/v2.7.0/corestats-v2.7.0.tar.gz
+ md5sums = 622921807dd694d70ec646e7d569087c
+
+pkgname = corestats
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9c7e00c205e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Shaber
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+pkgname=corestats
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="A system resource viewer from the CoreApps family."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/cubocore/$pkgname"
+license=('GPL3')
+depends=('qt5-base' 'libcprime' 'libcsys')
+groups=('coreapps')
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('622921807dd694d70ec646e7d569087c')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd ${pkgname}-v${pkgver}
+
+ qmake-qt5 ${pkgname}.pro
+ make
+}
+
+package() {
+ cd ${pkgname}-v${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+}