summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:37:02 +0530
committerlibrewish2020-01-24 23:37:02 +0530
commit40c4b9ac84755eb2aae855c49cd585220c233cee (patch)
tree1ffbee472a9f352d4342aeeba03c1c22fde4a5ed
downloadaur-40c4b9ac84755eb2aae855c49cd585220c233cee.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..001b7adfafa0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = corestats-git
+ pkgdesc = A system resource viewer from the CoreApps family.
+ pkgver = v2.8.0.r2.bbc1c66
+ pkgrel = 1
+ url = https://gitlab.com/cubocore
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = GPL3
+ makedepends = git
+ depends = libcprime-git
+ depends = libcsys-git
+ provides = corestats
+ conflicts = corestats
+ source = git+https://gitlab.com/cubocore/corestats.git
+ md5sums = SKIP
+
+pkgname = corestats-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b66b03084ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=corestats
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r2.bbc1c66
+pkgrel=1
+pkgdesc="A system resource viewer from the CoreApps family."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore"
+license=('GPL3')
+depends=('libcprime-git' 'libcsys-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}