summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:37:37 +0530
committerlibrewish2020-01-24 23:37:37 +0530
commitbcb26fb6e75933e1d772d5dfee5fcbd5ba30d6a7 (patch)
tree25851bed3d4b7228ec9acd0c8ef5e46f4d58bc1b
downloadaur-bcb26fb6e75933e1d772d5dfee5fcbd5ba30d6a7.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baa9cd2be09b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = corestuff-git
+ pkgdesc = An activity viewer from the CoreApps family.
+ pkgver = v2.8.0.r3.1d9337b
+ pkgrel = 1
+ url = https://gitlab.com/cubocore
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = GPL3
+ makedepends = git
+ depends = qt5-x11extras
+ depends = libcprime-git
+ depends = libcsys-git
+ provides = corestuff
+ conflicts = corestuff
+ source = git+https://gitlab.com/cubocore/corestuff.git
+ md5sums = SKIP
+
+pkgname = corestuff-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f08bd9c8b92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=corestuff
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r3.1d9337b
+pkgrel=1
+pkgdesc="An activity viewer from the CoreApps family."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore"
+license=('GPL3')
+depends=('qt5-x11extras' 'libcprime-git' 'libcsys-git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}