summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:39:55 +0530
committerlibrewish2020-01-24 23:39:55 +0530
commit697b1187e0e99f94176209fb24b72d0f92a39a91 (patch)
tree92ba64d718ea772d54b3a078fddd4d3f9f765263
downloadaur-697b1187e0e99f94176209fb24b72d0f92a39a91.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a73684a5055
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = coretoppings-git
+ pkgdesc = Additional features, plugins, widgets etc for CuboCore Application Suite.
+ pkgver = v2.8.0.r1.126a8cf
+ pkgrel = 1
+ url = https://gitlab.com/cubocore
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = GPL3
+ makedepends = git
+ depends = libcprime
+ depends = qt5-x11extras
+ depends = qt5-connectivity
+ depends = qt5-location
+ depends = libxcomposite
+ depends = libpulse
+ provides = coretoppings
+ conflicts = coretoppings
+ source = git+https://gitlab.com/cubocore/coretoppings.git
+ md5sums = SKIP
+
+pkgname = coretoppings-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19d22083d49b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=coretoppings
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r1.126a8cf
+pkgrel=1
+pkgdesc="Additional features, plugins, widgets etc for CuboCore Application Suite."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore"
+license=('GPL3')
+depends=('libcprime' 'qt5-x11extras' 'qt5-connectivity' 'qt5-location' 'libxcomposite' 'libpulse')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}